CVE-2026-28813 Apache JSPWiki: JSPWiki vulnerable to JSON hijacking

High 8.8 Published Updated

Attackers can exploit JSON hijacking to perform CSRF attacks, requiring users to upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-28813?

CVE-2026-28813 is a high-severity vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities. Users are recommended to upgrade to version 2.12.4, which fixes this issue.

Weakness: CWE-352

Which versions are affected by CVE-2026-28813?

It affects 1 product.

Products include Apache Jspwiki.

How do I fix CVE-2026-28813?

No fix has been published for CVE-2026-28813 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-28813 being exploited?

There is no known exploitation of CVE-2026-28813 in the wild and no public exploit code.

Sources

Also known as GHSA-59wm-6vhj-9fgr.

Is CVE-2026-28813 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free