# CVE-2026-28813: Apache JSPWiki: JSPWiki vulnerable to JSON hijacking

> Attackers can exploit JSON hijacking to perform CSRF attacks, requiring users to upgrade to the latest version.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-59wm-6vhj-9fgr

## What is CVE-2026-28813?

CVE-2026-28813 is a high-severity vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities.
Users are recommended to upgrade to version 2.12.4, which fixes this issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-28813?

It affects 1 product.


Products: Apache Jspwiki.

## How do I fix CVE-2026-28813?

No fix has been published for CVE-2026-28813 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28813 being exploited?

There is no known exploitation of CVE-2026-28813 in the wild and no public exploit code.

## Other vulnerabilities in Apache JSPWiki

- [CVE-2026-28812](https://insights.sbomify.com/CVE-2026-28812/): Apache JSPWiki: UserManager does not sanity-check user database at startup (critical 9.8)
- [CVE-2021-44140](https://insights.sbomify.com/CVE-2021-44140/): Arbitrary file deletion on logout (critical 9.1)
- [CVE-2022-34158](https://insights.sbomify.com/CVE-2022-34158/): User Group Privilege Escalation (high 8.8)
- [CVE-2022-24947](https://insights.sbomify.com/CVE-2022-24947/): Apache JSPWiki CSRF Account Takeover (high 8.8)
- [CVE-2026-28811](https://insights.sbomify.com/CVE-2026-28811/): Apache JSPWiki: Error Handling - Reveals Error Details (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28813 and fix it if it is affected.

What it is: CVE-2026-28813 is a high-severity vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28813 in the wild and no public exploit code.

Affected product: Apache JSPWiki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28813/ (Markdown: https://insights.sbomify.com/CVE-2026-28813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28813
- OSV: https://osv.dev/vulnerability/CVE-2026-28813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28813/
Summaries are generated and may contain mistakes; the official description above is the record.
