CVE-2026-28814 Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
Attackers can access sensitive data stored in JSPWiki variables by exploiting missing authentication checks during wiki markup rendering.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-28814?
CVE-2026-28814 is a high-severity missing authorization vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain sensitive data stored in JSPWiki variables. Users are recommended to upgrade to version 2.12.4 or 3.0.0, which fixes this issue.
Weakness: CWE-306
Which versions are affected by CVE-2026-28814?
It affects 1 product.
Products include Apache Jspwiki.
How do I fix CVE-2026-28814?
No fix has been published for CVE-2026-28814 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-28814 being exploited?
There is no known exploitation of CVE-2026-28814 in the wild and no public exploit code.
Other vulnerabilities in Apache JSPWiki
- CVE-2026-28812 Apache JSPWiki: UserManager does not sanity-check user database at startup
- CVE-2021-44140 Arbitrary file deletion on logout
- CVE-2026-28813 Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
- CVE-2022-34158 User Group Privilege Escalation
- CVE-2022-24947 Apache JSPWiki CSRF Account Takeover
Sources
Also known as GHSA-9c4x-gmwm-cj68.