# CVE-2026-28814: Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering

> Attackers can access sensitive data stored in JSPWiki variables by exploiting missing authentication checks during wiki markup rendering.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-9c4x-gmwm-cj68

## What is CVE-2026-28814?

CVE-2026-28814 is a high-severity missing authorization vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain sensitive data stored in JSPWiki variables.
Users are recommended to upgrade to version 2.12.4 or 3.0.0, which fixes this issue.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-28814?

It affects 1 product.


Products: Apache Jspwiki.

## How do I fix CVE-2026-28814?

No fix has been published for CVE-2026-28814 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28814 being exploited?

There is no known exploitation of CVE-2026-28814 in the wild and no public exploit code.

## Other vulnerabilities in Apache JSPWiki

- [CVE-2026-28812](https://insights.sbomify.com/CVE-2026-28812/): Apache JSPWiki: UserManager does not sanity-check user database at startup (critical 9.8)
- [CVE-2021-44140](https://insights.sbomify.com/CVE-2021-44140/): Arbitrary file deletion on logout (critical 9.1)
- [CVE-2026-28813](https://insights.sbomify.com/CVE-2026-28813/): Apache JSPWiki: JSPWiki vulnerable to JSON hijacking (high 8.8)
- [CVE-2022-34158](https://insights.sbomify.com/CVE-2022-34158/): User Group Privilege Escalation (high 8.8)
- [CVE-2022-24947](https://insights.sbomify.com/CVE-2022-24947/): Apache JSPWiki CSRF Account Takeover (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28814 and fix it if it is affected.

What it is: CVE-2026-28814 is a high-severity missing authorization vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28814 in the wild and no public exploit code.

Affected product: Apache JSPWiki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28814/ (Markdown: https://insights.sbomify.com/CVE-2026-28814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28814
- OSV: https://osv.dev/vulnerability/CVE-2026-28814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28814/
Summaries are generated and may contain mistakes; the official description above is the record.
