# CVE-2026-28815: Swift Crypto: X-Wing HPKE Decapsulation Accepts Malformed Ciphertext Length

> A remote attacker can trigger an out-of-bounds read in the swift-crypto library, potentially causing crashes or memory disclosure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-9m44-rr2w-ppp7

## What is CVE-2026-28815?

CVE-2026-28815 is a high-severity vulnerability in Apple macOS, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A remote attacker can supply a short X-Wing HPKE encapsulated key and trigger an out-of-bounds read in the C decapsulation path, potentially causing a crash or memory disclosure depending on runtime protections. This issue is fixed in swift-crypto version 4.3.1.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-28815?

2 open source packages ship an affected version, including swift-crypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift-crypto` | SwiftURL | From 4.0.0 | 4.3.1 |
| `swift-crypto` | SwiftURL | From 4.0.0 | 4.3.1 |

Products: Apple Swift-Crypto.

## How do I fix CVE-2026-28815?

Upgrade swift-crypto to 4.3.1 or later.

## Is CVE-2026-28815 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28815 exists.

## Other vulnerabilities in Apple macOS

- [CVE-2026-43823](https://insights.sbomify.com/CVE-2026-43823/): When initializing an RSA public key from DER or PEM bytes throws an error, the EVP_PKEY* is double-freed: first in the catch block, then in the deinit. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28815 and fix it if it is affected.

What it is: CVE-2026-28815 is a high-severity vulnerability in Apple macOS, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28815 exists.

Affected packages and fixed versions:
- swift-crypto (SwiftURL): affected from 4.0.0; fixed in 4.3.1
- swift-crypto (SwiftURL): affected from 4.0.0; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28815/ (Markdown: https://insights.sbomify.com/CVE-2026-28815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28815
- OSV: https://osv.dev/vulnerability/CVE-2026-28815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28815/
Summaries are generated and may contain mistakes; the official description above is the record.
