CVE-2026-2900 Missing Authorization in GitLab

Low 2.7 Published Updated

Authenticated Maintainers can modify or delete project approval rules when instance-level prevention is enabled due to missing authorization checks.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-2900?

CVE-2026-2900 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 16.10 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that when instance-level approval rule editing prevention was enabled, could have allowed an authenticated user with Maintainer permissions to modify or delete project approval rules due to missing authorization checks.

Weakness: CWE-862

Which versions are affected by CVE-2026-2900?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.10.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-2900?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-2900 being exploited?

There is no known exploitation of CVE-2026-2900 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-2900, GHSA-8xwh-m77v-v26p, UBUNTU-CVE-2026-2900.

Is CVE-2026-2900 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free