# CVE-2026-29000: pac4j-jwt JwtAuthenticator Authentication Bypass

> Attackers with the server's RSA public key can forge JWTs to bypass authentication and gain administrator access in applications using pac4j-jwt.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-pm7g-w2cf-q238

## What is CVE-2026-29000?

CVE-2026-29000 is a critical authentication bypass vulnerability in pac4j-jwt, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pac4j-jwt versions prior to 4.5.9, 5.7.9, and 6.3.3 contain an authentication bypass vulnerability in JwtAuthenticator when processing encrypted JWTs that allows remote attackers to forge authentication tokens. Attackers who possess the server's RSA public key can create a JWE-wrapped PlainJWT with arbitrary subject and role claims, bypassing signature verification to authenticate as any user including administrators.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-29000?

6 open source packages ship an affected version, including org.pac4j:pac4j-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.pac4j:pac4j-jwt` | Maven | All versions | 4.5.9 |
| `org.pac4j:pac4j-jwt` | Maven | All versions | 4.5.9 |
| `org.pac4j:pac4j-jwt` | Maven | From 5.0.0-RC1 | 5.7.9 |
| `org.pac4j:pac4j-jwt` | Maven | From 5.0.0-RC1 | 5.7.9 |
| `org.pac4j:pac4j-jwt` | Maven | From 6.0.4.1 | 6.3.3 |
| `org.pac4j:pac4j-jwt` | Maven | From 6.0.4.1 | 6.3.3 |

## How do I fix CVE-2026-29000?

Upgrade org.pac4j:pac4j-jwt to a fixed version for your release line: 4.5.9, 5.7.9 or 6.3.3.

## Is CVE-2026-29000 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29000 exists.

Public exploit code:

- pac4j-jwt JwtAuthenticator auth bypass (CVE-2026-29000) writeup and PoCs (github_poc): https://github.com/kernelzeroday/CVE-2026-29000
- CVE-2026-29000 PoC: pac4j-jwt PlainJWT-in-JWE authentication bypass. (github_poc): https://github.com/Strikoder-Premium/CVE-2026-29000-pac4j-jwt
- CVE-2026-29000 – pac4j-jwt Authentication Bypass (CVSS 10.0). One-click admin forge via public key JWE wrapping. Leaks configs, users, secrets. Keep-alive, proxy, custom JWKS. Educational PoC Exploit tool. (github_poc): https://github.com/tc4dy/CVE-2026-29000-PoC-Exploit
- https://github.com/alihussainzada/CVE-2026-29000-Python-PoC-pac4j-JWT-AuthenticationBypass-Poc (github_poc): https://github.com/alihussainzada/CVE-2026-29000-Python-PoC-pac4j-JWT-AuthenticationBypass-Poc
- cve-2026-29000 exploit (github_poc): https://github.com/RootX111/cve-2026-29000
- CVE-2026-29000 - pac4j-jwt Authentication Bypass PoC (github_poc): https://github.com/manbahadurthapa1248/CVE-2026-29000---pac4j-jwt-Authentication-Bypass-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29000 and fix it if it is affected.

What it is: CVE-2026-29000 is a critical authentication bypass vulnerability in pac4j-jwt, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29000 exists.

Affected packages and fixed versions:
- org.pac4j:pac4j-jwt (Maven): affected all versions; fixed in 4.5.9
- org.pac4j:pac4j-jwt (Maven): affected all versions; fixed in 4.5.9
- org.pac4j:pac4j-jwt (Maven): affected from 5.0.0-RC1; fixed in 5.7.9
- org.pac4j:pac4j-jwt (Maven): affected from 5.0.0-RC1; fixed in 5.7.9
- org.pac4j:pac4j-jwt (Maven): affected from 6.0.4.1; fixed in 6.3.3
- org.pac4j:pac4j-jwt (Maven): affected from 6.0.4.1; fixed in 6.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29000/ (Markdown: https://insights.sbomify.com/CVE-2026-29000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29000
- OSV: https://osv.dev/vulnerability/CVE-2026-29000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29000/
Summaries are generated and may contain mistakes; the official description above is the record.
