# CVE-2026-29038: changedetection.io: Reflected XSS in RSS Tag Error Response

> Reflected XSS in changedetection.io allows attackers to execute arbitrary JavaScript in victim browsers via the RSS tag endpoint.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-8whx-v8qq-pq64, PYSEC-2026-2127

## What is CVE-2026-29038?

CVE-2026-29038 is a medium-severity cross-site scripting vulnerability in dgtlmoon changedetection.io, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

changedetection.io is a free open source web page change detection tool. Prior to version 0.54.4, there is a reflected cross-site scripting (XSS) vulnerability identified in the /rss/tag/ endpoint of changedetection.io. The tag_uuid path parameter is reflected directly in the HTTP response body without HTML escaping. Since Flask returns text/html by default for plain string responses, the browser parses and executes injected JavaScript. This issue has been patched in version 0.54.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-29038?

3 open source packages ship an affected version, including changedetection.io and changedetection-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.54.4 |
| `changedetection-io` | PyPI | All versions | 0.54.4 |
| `changedetection-io` | PyPI | All versions | 0.54.4 |

Products: Webtechnologies Changedetection.

## How do I fix CVE-2026-29038?

Upgrade changedetection.io to 0.54.4 or later.

## Is CVE-2026-29038 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29038 exists.

## Other vulnerabilities in dgtlmoon changedetection.io

- [CVE-2026-35490](https://insights.sbomify.com/CVE-2026-35490/): changedetection.io has an Authentication Bypass via Decorator Ordering (critical 9.8)
- [CVE-2026-29039](https://insights.sbomify.com/CVE-2026-29039/): changedetection.io: XPath - Arbitrary File Read via unparsed-text() (high 8.8)
- [CVE-2026-29065](https://insights.sbomify.com/CVE-2026-29065/): changedetection.io: Zip Slip vulnerability in the backup restore functionality (high 8.8)
- [CVE-2026-27696](https://insights.sbomify.com/CVE-2026-27696/): changedetection.io Vulnerable to Server-Side Request Forgery (SSRF) via Watch URLs (high 8.6)
- [CVE-2026-33981](https://insights.sbomify.com/CVE-2026-33981/): Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29038 and fix it if it is affected.

What it is: CVE-2026-29038 is a medium-severity cross-site scripting vulnerability in dgtlmoon changedetection.io, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29038 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.54.4
- changedetection-io (PyPI): affected all versions; fixed in 0.54.4
- changedetection-io (PyPI): affected all versions; fixed in 0.54.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29038/ (Markdown: https://insights.sbomify.com/CVE-2026-29038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29038
- OSV: https://osv.dev/vulnerability/CVE-2026-29038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29038/
Summaries are generated and may contain mistakes; the official description above is the record.
