# CVE-2026-29039: changedetection.io: XPath - Arbitrary File Read via unparsed-text()

> Attackers can read arbitrary files from the server by injecting malicious XPath expressions into content filters, exposing sensitive data.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-6fmw-82m7-jq6p, PYSEC-2026-2128

## What is CVE-2026-29039?

CVE-2026-29039 is a high-severity code injection vulnerability in dgtlmoon changedetection.io, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

changedetection.io is a free open source web page change detection tool. Prior to version 0.54.4, the changedetection.io application allows users to specify XPath expressions as content filters via the include_filters field. These XPath expressions are processed using the elementpath library which implements XPath 3.0/3.1 specification. XPath 3.0 includes the unparsed-text() function which can read arbitrary files from the filesystem. The application does not validate or sanitize XPath expressions to block dangerous functions, allowing an attacker to read any file accessible to the application process. This issue has been patched in version 0.54.4.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-29039?

3 open source packages ship an affected version, including changedetection.io and changedetection-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.54.4 |
| `changedetection-io` | PyPI | All versions | 0.54.4 |
| `changedetection-io` | PyPI | All versions | 0.54.4 |

Products: Webtechnologies Changedetection.

## How do I fix CVE-2026-29039?

Upgrade changedetection.io to 0.54.4 or later.

## Is CVE-2026-29039 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29039 exists.

## Other vulnerabilities in dgtlmoon changedetection.io

- [CVE-2026-35490](https://insights.sbomify.com/CVE-2026-35490/): changedetection.io has an Authentication Bypass via Decorator Ordering (critical 9.8)
- [CVE-2026-29065](https://insights.sbomify.com/CVE-2026-29065/): changedetection.io: Zip Slip vulnerability in the backup restore functionality (high 8.8)
- [CVE-2026-27696](https://insights.sbomify.com/CVE-2026-27696/): changedetection.io Vulnerable to Server-Side Request Forgery (SSRF) via Watch URLs (high 8.6)
- [CVE-2026-33981](https://insights.sbomify.com/CVE-2026-33981/): Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters (high 8.3)
- [CVE-2026-41895](https://insights.sbomify.com/CVE-2026-41895/): changedetection.io: XXE vulnerability in the changedetection.io project (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29039 and fix it if it is affected.

What it is: CVE-2026-29039 is a high-severity code injection vulnerability in dgtlmoon changedetection.io, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29039 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.54.4
- changedetection-io (PyPI): affected all versions; fixed in 0.54.4
- changedetection-io (PyPI): affected all versions; fixed in 0.54.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29039/ (Markdown: https://insights.sbomify.com/CVE-2026-29039/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29039
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29039
- OSV: https://osv.dev/vulnerability/CVE-2026-29039

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29039/
Summaries are generated and may contain mistakes; the official description above is the record.
