# CVE-2026-29042: Nuclio Shell Runtime Command Injection Leading to Privilege Escalation

> Attackers can execute arbitrary commands and escalate privileges by injecting malicious input into the X-Nuclio-Arguments header in Nuclio Shell Runtime.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-95fj-3w7g-4r27, GO-2026-4598

## What is CVE-2026-29042?

CVE-2026-29042 is a high-severity command injection vulnerability in nuclio, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nuclio is a "Serverless" framework for Real-Time Events and Data Processing. Prior to version 1.15.20, the Nuclio Shell Runtime component contains a command injection vulnerability in how it processes user-supplied arguments. When a function is invoked via HTTP, the runtime reads the X-Nuclio-Arguments header and directly incorporates its value into shell commands without any validation or sanitization. This issue has been patched in version 1.15.20.

Weakness: CWE-75 (Failure to Sanitize Special Elements into a Different Plane)

## Which versions are affected by CVE-2026-29042?

3 open source packages ship an affected version, including github.com/nuclio/nuclio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nuclio/nuclio` | Go | All versions | None |
| `github.com/nuclio/nuclio` | Go | All versions | 1.15.20 |
| `github.com/nuclio/nuclio` | Go | All versions | 1.15.20 |

Products: Iguazio Nuclio.

## How do I fix CVE-2026-29042?

Upgrade github.com/nuclio/nuclio to 1.15.20 or later.

## Is CVE-2026-29042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29042 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29042 and fix it if it is affected.

What it is: CVE-2026-29042 is a high-severity command injection vulnerability in nuclio, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29042 exists.

Affected packages and fixed versions:
- github.com/nuclio/nuclio (Go): affected all versions; no fix listed
- github.com/nuclio/nuclio (Go): affected all versions; fixed in 1.15.20
- github.com/nuclio/nuclio (Go): affected all versions; fixed in 1.15.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29042/ (Markdown: https://insights.sbomify.com/CVE-2026-29042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29042
- OSV: https://osv.dev/vulnerability/CVE-2026-29042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29042/
Summaries are generated and may contain mistakes; the official description above is the record.
