CVE-2026-29047 GLPI has an Authenticated SQL Injection via log exports
Authenticated users can execute SQL injection attacks via the log export feature in GLPI, potentially compromising database integrity and confidentiality.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-29047?
CVE-2026-29047 is a high-severity SQL injection vulnerability in Glpi-Project Glpi, published on 6 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GLPI is a free asset and IT management software package. From 10.0.0 to before 10.0.24 and 11.0.6, an authenticated user can perform a SQL injection via the logs export feature. This vulnerability is fixed in 10.0.24 and 11.0.6.
Weakness: CWE-89
Which versions are affected by CVE-2026-29047?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2026-29047?
No fix has been published for CVE-2026-29047 yet. Limit exposure of the affected software until one is available.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-29047 being exploited?
There is no known exploitation of CVE-2026-29047 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-3m49-qf92-vccr, UBUNTU-CVE-2026-29047.