# CVE-2026-29048: HumHub: XSS in Button component

> Attackers can inject malicious scripts via the Button component, potentially executing code in user browsers and compromising accounts.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-qxjh-478x-23gm

## What is CVE-2026-29048?

CVE-2026-29048 is a medium-severity cross-site scripting vulnerability in humhub, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HumHub is an Open Source Enterprise Social Network. In version 1.18.0, a cross-site scripting vulnerability was identified in the Button component of version 1.18.0. Due to inconsistent output encoding at several points within the software, malicious scripts could be injected and executed in the context of the user's browser. This issue has been patched in version 1.18.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-29048?

It affects 1 product.


Products: Humhub Humhub.

## How do I fix CVE-2026-29048?

No fix has been published for CVE-2026-29048 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-29048 being exploited?

There is no known exploitation of CVE-2026-29048 in the wild and no public exploit code.

## Other vulnerabilities in humhub

- [CVE-2014-9528](https://insights.sbomify.com/CVE-2014-9528/): SQL injection in n/a (high 7.5)
- [CVE-2025-64442](https://insights.sbomify.com/CVE-2025-64442/): HumHub is vulnerable to XSS through its Meta Search component (high 7.1)
- [CVE-2024-52043](https://insights.sbomify.com/CVE-2024-52043/): User enumeration in HubHub (medium 6.9)
- [CVE-2022-24865](https://insights.sbomify.com/CVE-2022-24865/): Improper access control in humhub (medium 6.5)
- [CVE-2021-43847](https://insights.sbomify.com/CVE-2021-43847/): Authorization Bypass in Space Invite in HumHub (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29048 and fix it if it is affected.

What it is: CVE-2026-29048 is a medium-severity cross-site scripting vulnerability in humhub, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29048 in the wild and no public exploit code.

Affected product: humhub. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29048/ (Markdown: https://insights.sbomify.com/CVE-2026-29048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29048
- OSV: https://osv.dev/vulnerability/CVE-2026-29048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29048/
Summaries are generated and may contain mistakes; the official description above is the record.
