CVE-2026-29050 melange has Path Traversal When Resolving External Pipelines via Unvalidated pipeline[].uses

Medium 6.1 Published Updated

Attackers can execute arbitrary shell commands and read files by manipulating pipeline paths in melange configuration files during builds.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-29050?

CVE-2026-29050 is a medium-severity path traversal vulnerability in chainguard-dev melange, published on 23 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

melange allows users to build apk packages using declarative pipelines. Starting in version 0.32.0 and prior to version 0.43.4, an attacker who can influence a melange configuration file — for example through pull-request-driven CI or build-as-a-service scenarios — could set `pipeline[].uses` to a value containing `../` sequences or an absolute path. The `(*Compiled).compilePipeline` function in `pkg/build/compile.go` passed `uses` directly to `filepath.Join(pipelineDir, uses + ".yaml")` without validating the value, so the resolved path could escape each `--pipeline-dir` and read an arbitrary YAML-parseable file visible to the melange process. Because the loaded file is subsequently interpreted as a melange pipeline and its `runs:` block is executed via `/bin/sh -c` in the build sandbox, this additionally allowed shell commands sourced from an out-of-tree file to run during the build, bypassing the review boundary that normally covers the in-tree pipeline definition. The issue is fixed in melange v0.43.4 via commit 5829ca4. The fix rejects `uses` values that are absolute paths or contain `..`, and verifies (via `filepath.Rel` after `filepath.Clean`) that the resolved target remains within the pipeline directory. As a workaround, only run `melange build` against configuration files from trusted sources. In CI systems that build user-supplied melange configs, gate builds behind manual review of `pipeline[].uses` values and reject any containing `..` or leading `/`.

Weakness: CWE-22

Which versions are affected by CVE-2026-29050?

3 open source packages ship an affected version, including chainguard.dev/melange. It affects 1 product.

PackageAffectedFixed in
chainguard.dev/melange GoFrom 0.32.00.43.4
chainguard.dev/melange GoFrom 0.32.00.43.4
chainguard.dev/melange GoFrom 0.32.00.43.4

Products include Chainguard Melange.

How do I fix CVE-2026-29050?

Upgrade chainguard.dev/melange to 0.43.4 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-29050 being exploited?

There is no known exploitation of CVE-2026-29050 in the wild and no public exploit code.

Sources

Also known as GHSA-98f2-w9h9-7fp9, GO-2026-5279.

Is CVE-2026-29050 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free