# CVE-2026-29050: melange has Path Traversal When Resolving External Pipelines via Unvalidated pipeline[].uses

> Attackers can execute arbitrary shell commands and read files by manipulating pipeline paths in melange configuration files during builds.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 25 Apr 2026
- **Also known as:** GHSA-98f2-w9h9-7fp9, GO-2026-5279

## What is CVE-2026-29050?

CVE-2026-29050 is a medium-severity path traversal vulnerability in chainguard-dev melange, published on 23 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

melange allows users to build apk packages using declarative pipelines. Starting in version 0.32.0 and prior to version 0.43.4, an attacker who can influence a melange configuration file — for example through pull-request-driven CI or build-as-a-service scenarios — could set `pipeline[].uses` to a value containing `../` sequences or an absolute path. The `(*Compiled).compilePipeline` function in `pkg/build/compile.go` passed `uses` directly to `filepath.Join(pipelineDir, uses + ".yaml")` without validating the value, so the resolved path could escape each `--pipeline-dir` and read an arbitrary YAML-parseable file visible to the melange process. Because the loaded file is subsequently interpreted as a melange pipeline and its `runs:` block is executed via `/bin/sh -c` in the build sandbox, this additionally allowed shell commands sourced from an out-of-tree file to run during the build, bypassing the review boundary that normally covers the in-tree pipeline definition. The issue is fixed in melange v0.43.4 via commit 5829ca4. The fix rejects `uses` values that are absolute paths or contain `..`, and verifies (via `filepath.Rel` after `filepath.Clean`) that the resolved target remains within the pipeline directory. As a workaround, only run `melange build` against configuration files from trusted sources. In CI systems that build user-supplied melange configs, gate builds behind manual review of `pipeline[].uses` values and reject any containing `..` or leading `/`.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-29050?

3 open source packages ship an affected version, including chainguard.dev/melange. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/melange` | Go | From 0.32.0 | 0.43.4 |
| `chainguard.dev/melange` | Go | From 0.32.0 | 0.43.4 |
| `chainguard.dev/melange` | Go | From 0.32.0 | 0.43.4 |

Products: Chainguard Melange.

## How do I fix CVE-2026-29050?

Upgrade chainguard.dev/melange to 0.43.4 or later.

## Is CVE-2026-29050 being exploited?

There is no known exploitation of CVE-2026-29050 in the wild and no public exploit code.

## Other vulnerabilities in chainguard-dev melange

- [CVE-2026-24843](https://insights.sbomify.com/CVE-2026-24843/): melange QEMU runner could write files outside workspace directory (high 8.2)
- [CVE-2026-24844](https://insights.sbomify.com/CVE-2026-24844/): melange pipeline working-directory could allow command injection (high 7.8)
- [CVE-2026-25143](https://insights.sbomify.com/CVE-2026-25143/): melange affected by potential host command execution via license-check YAML mode patch pipeline (high 7.8)
- [CVE-2026-25145](https://insights.sbomify.com/CVE-2026-25145/): melange has a path traversal in license-path which allows reading files outside workspace (medium 5.5)
- [CVE-2026-29051](https://insights.sbomify.com/CVE-2026-29051/): melange has Path Traversal via .PKGINFO in --persist-lint-results (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29050 and fix it if it is affected.

What it is: CVE-2026-29050 is a medium-severity path traversal vulnerability in chainguard-dev melange, published on 23 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29050 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/melange (Go): affected from 0.32.0; fixed in 0.43.4
- chainguard.dev/melange (Go): affected from 0.32.0; fixed in 0.43.4
- chainguard.dev/melange (Go): affected from 0.32.0; fixed in 0.43.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29050/ (Markdown: https://insights.sbomify.com/CVE-2026-29050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29050
- OSV: https://osv.dev/vulnerability/CVE-2026-29050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29050/
Summaries are generated and may contain mistakes; the official description above is the record.
