CVE-2026-29053 Ghost Vulnerable to Remote Code Execution via Malicious Themes

High 7.7 Published Updated

Attackers can execute arbitrary code on Ghost servers by uploading malicious themes, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-29053?

CVE-2026-29053 is a high-severity code injection vulnerability in TryGhost Ghost, published on 5 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Weakness: CWE-74

Which versions are affected by CVE-2026-29053?

3 open source packages ship an affected version, including ghost. It affects 1 product.

PackageAffectedFixed in
ghost BitnamiFrom 0.7.26.19.1
ghost npmFrom 0.7.26.19.1
ghost npmFrom 0.7.26.19.1

Products include Ghost Ghost.

How do I fix CVE-2026-29053?

Upgrade ghost to 6.19.1 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-29053 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29053 exists.

Public exploit code: 1 Metasploit module, 1 Exploit-DB entry and 2 proofs of concept on GitHub.

Sources

Also known as BIT-ghost-2026-29053, GHSA-cgc2-rcrh-qr5x.

Is CVE-2026-29053 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free