CVE-2026-29057 Next.js: HTTP request smuggling in rewrites
Attackers can smuggle requests to internal backend routes via crafted chunked requests in Next.js rewrites, bypassing access controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29057?
CVE-2026-29057 is a medium-severity vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Next.js is a React framework for building full-stack web applications. Starting in version 9.5.0 and prior to versions 15.5.13 and 16.1.7, when Next.js rewrites proxy traffic to an external backend, a crafted `DELETE`/`OPTIONS` request using `Transfer-Encoding: chunked` could trigger request boundary disagreement between the proxy and backend. This could allow request smuggling through rewritten routes. An attacker could smuggle a second request to unintended backend routes (for example, internal/admin endpoints), bypassing assumptions that only the configured rewrite destination/path is reachable. This does not impact applications hosted on providers that handle rewrites at the CDN level, such as Vercel. The vulnerability originated in an upstream library vendored by Next.js. It is fixed in Next.js 15.5.13 and 16.1.7 by updating that dependency’s behavior so `content-length: 0` is added only when both `content-length` and `transfer-encoding` are absent, and `transfer-encoding` is no longer removed in that code path. If upgrading is not immediately possible, block chunked `DELETE`/`OPTIONS` requests on rewritten routes at the edge/proxy, and/or enforce authentication/authorization on backend routes.
Weakness: CWE-444
Which versions are affected by CVE-2026-29057?
4 open source packages ship an affected version, including next. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
next npm | From 16.0.0-beta.0 | 16.1.7 |
next npm | From 16.0.0-beta.0 | 16.1.7 |
next npm | From 9.5.0 | 15.5.13 |
next npm | From 9.5.0 | 15.5.13 |
Products include Vercel Next.js.
How do I fix CVE-2026-29057?
Upgrade next to a fixed version for your release line: 16.1.7 or 15.5.13.
Is CVE-2026-29057 being exploited?
There is no known exploitation of CVE-2026-29057 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Vercel Next.js
- CVE-2025-29927 Authorization Bypass in Next.js Middleware
- CVE-2026-44578 Next.js: Server-side request forgery in applications using WebSocket upgrades
- CVE-2026-94483 Next.js: Server-Side Request Forgery in Image Optimization
- CVE-2026-64642 Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale
- CVE-2026-64645 Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname
Sources
Also known as GHSA-ggv3-7p47-pfv8, MINI-887h-rhvp-rjjm, MINI-h7qm-rcmr-cvgr, MINI-r8qf-gg2v-j7jc, ROOT-APP-NPM-CVE-2026-29057.