# CVE-2026-29057: Next.js: HTTP request smuggling in rewrites

> Attackers can smuggle requests to internal backend routes via crafted chunked requests in Next.js rewrites, bypassing access controls.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-ggv3-7p47-pfv8, MINI-887h-rhvp-rjjm, MINI-h7qm-rcmr-cvgr, MINI-r8qf-gg2v-j7jc, ROOT-APP-NPM-CVE-2026-29057

## What is CVE-2026-29057?

CVE-2026-29057 is a medium-severity vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. Starting in version 9.5.0 and prior to versions 15.5.13 and 16.1.7, when Next.js rewrites proxy traffic to an external backend, a crafted `DELETE`/`OPTIONS` request using `Transfer-Encoding: chunked` could trigger request boundary disagreement between the proxy and backend. This could allow request smuggling through rewritten routes. An attacker could smuggle a second request to unintended backend routes (for example, internal/admin endpoints), bypassing assumptions that only the configured rewrite destination/path is reachable. This does not impact applications hosted on providers that handle rewrites at the CDN level, such as Vercel.  The vulnerability originated in an upstream library vendored by Next.js. It is fixed in Next.js 15.5.13 and 16.1.7 by updating that dependency’s behavior so `content-length: 0` is added only when both `content-length` and `transfer-encoding` are absent, and `transfer-encoding` is no longer removed in that code path. If upgrading is not immediately possible, block chunked `DELETE`/`OPTIONS` requests on rewritten routes at the edge/proxy, and/or enforce authentication/authorization on backend routes.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-29057?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 16.0.0-beta.0 | 16.1.7 |
| `next` | npm | From 16.0.0-beta.0 | 16.1.7 |
| `next` | npm | From 9.5.0 | 15.5.13 |
| `next` | npm | From 9.5.0 | 15.5.13 |

Products: Vercel Next.js.

## How do I fix CVE-2026-29057?

Upgrade next to a fixed version for your release line: 16.1.7 or 15.5.13.

## Is CVE-2026-29057 being exploited?

There is no known exploitation of CVE-2026-29057 in the wild and no public exploit code.

Public exploit code:

- https://github.com/learnerxuan/CVE-2026-29057-POC (github_poc): https://github.com/learnerxuan/CVE-2026-29057-POC

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29057 and fix it if it is affected.

What it is: CVE-2026-29057 is a medium-severity vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29057 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 16.0.0-beta.0; fixed in 16.1.7
- next (npm): affected from 16.0.0-beta.0; fixed in 16.1.7
- next (npm): affected from 9.5.0; fixed in 15.5.13
- next (npm): affected from 9.5.0; fixed in 15.5.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29057/ (Markdown: https://insights.sbomify.com/CVE-2026-29057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29057
- OSV: https://osv.dev/vulnerability/CVE-2026-29057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29057/
Summaries are generated and may contain mistakes; the official description above is the record.
