{"answers":{"affected":"2 open source packages ship an affected version, including tools.jackson.core:jackson-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-29062 in the wild and no public exploit code.","fix":"Upgrade tools.jackson.core:jackson-core to 3.1.0 or later.","what":"CVE-2026-29062 is a high-severity denial of service vulnerability in FasterXML jackson-core, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29062 and fix it if it is affected.\n\nWhat it is: CVE-2026-29062 is a high-severity denial of service vulnerability in FasterXML jackson-core, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-29062 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tools.jackson.core:jackson-core (Maven): affected from 3.0.0; fixed in 3.1.0\n- tools.jackson.core:jackson-core (Maven): affected from 3.0.0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29062/ (Markdown: https://insights.sbomify.com/CVE-2026-29062/index.md)","id":"CVE-2026-29062","markdown":"https://insights.sbomify.com/CVE-2026-29062/index.md","name":"CVE-2026-29062","record":{"aliases":["CLEANSTART-2026-DS38629","CLEANSTART-2026-TD10342","CLEANSTART-2026-ZD94014","ECHO-1b7a-451d-1afc","GHSA-6v53-7c9g-w56r","MINI-44wg-rqmc-mqwp","MINI-4m96-q568-8j46","MINI-4pvw-mv3q-9cgm","MINI-p696-f83h-556f","MINI-qx3p-2gc7-qx57","MINI-v362-g9x2-29wh","MINI-w2qr-96mf-xcp2","ROOT-APP-MAVEN-CVE-2026-29062","UBUNTU-CVE-2026-29062"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java JSON library","requires_auth":"none","summary":"Attackers can cause a Denial of Service in applications using jackson-core by supplying deeply nested JSON that bypasses nesting limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jackson-core","vendor":"fasterxml"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"},{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"jackson-core contains core low-level incremental (\"streaming\") parser and generator abstractions used by Jackson Data Processor. From version 3.0.0 to before version 3.1.0, the UTF8DataInputJsonParser, which is used when parsing from a java.io.DataInput source, bypasses the maxNestingDepth constraint (default: 500) defined in StreamReadConstraints. A similar issue was found in ReaderBasedJsonParser. This allows a user to supply a JSON document with excessive nesting, which can cause a StackOverflowError when the structure is processed, leading to a Denial of Service (DoS). This issue has been patched in version 3.1.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jackson-core: Nesting Depth Constraint Bypass in `UTF8DataInputJsonParser` potentially allowing Resource Exhaustion","id":"CVE-2026-29062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Immutable.js: Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') in immutable","id":"CVE-2026-29063"},"packages":[{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"tools.jackson.core:jackson-core","purl":null,"source":"GHSA-6v53-7c9g-w56r"},{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"tools.jackson.core:jackson-core","purl":"pkg:maven/tools.jackson.core/jackson-core","source":"GHSA-6v53-7c9g-w56r"}],"prev":{"headline":"Gokapi: Privilege escalation via incomplete API-key permission revocation on user rank demotion","id":"CVE-2026-29061"},"products":["jackson-core"],"published":"2026-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["FasterXML"]},"summary":"Attackers can cause a Denial of Service in applications using jackson-core by supplying deeply nested JSON that bypasses nesting limits.","url":"https://insights.sbomify.com/CVE-2026-29062/"}