# CVE-2026-29067: ZITADEL: Account Takeover Due to Improper Instance Validation in V2 Login

> Attackers can hijack password reset links by manipulating forwarded host headers, leading to account takeover in ZITADEL.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-pfrf-9r5f-73f5, GO-2025-4212

## What is CVE-2026-29067?

CVE-2026-29067 is a high-severity vulnerability in zitadel, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ZITADEL is an open source identity management platform. From version 4.0.0-rc.1 to 4.7.0, a potential vulnerability exists in ZITADEL's password reset mechanism in login V2. ZITADEL utilizes the Forwarded or X-Forwarded-Host header from incoming requests to construct the URL for the password reset confirmation link. This link, containing a secret code, is then emailed to the user. This issue has been patched in version 4.7.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-29067?

9 open source packages ship an affected version, including github.com/zitadel/zitadel and github.com/zitadel/zitadel/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251208091519-4c879b47334e |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251208091519-4c879b47334e |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251208091519-4c879b47334e |
| `github.com/zitadel/zitadel` | Go | From 1.83.4 to 1.87.5 | None |
| `github.com/zitadel/zitadel` | Go | From 1.83.4 to 1.87.5 | None |
| `github.com/zitadel/zitadel` | Go | From 4.0.0-rc.1 | 4.7.1 |
| `github.com/zitadel/zitadel` | Go | From 4.0.0-rc.1 | 4.7.1 |
| `github.com/zitadel/zitadel/v2` | Go | All versions | 1.80.0-v2.20.0.20251208091519-4c879b47334e |
| `github.com/zitadel/zitadel/v2` | Go | All versions | 1.80.0-v2.20.0.20251208091519-4c879b47334e |

Products: Zitadel Zitadel.

## How do I fix CVE-2026-29067?

Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 1.80.0-v2.20.0.20251208091519-4c879b47334e or 4.7.1.

## Is CVE-2026-29067 being exploited?

There is no known exploitation of CVE-2026-29067 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29067 and fix it if it is affected.

What it is: CVE-2026-29067 is a high-severity vulnerability in zitadel, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29067 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251208091519-4c879b47334e
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251208091519-4c879b47334e
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251208091519-4c879b47334e
- github.com/zitadel/zitadel (Go): affected from 1.83.4 up to 1.87.5; no fix listed
- github.com/zitadel/zitadel (Go): affected from 1.83.4 up to 1.87.5; no fix listed
- github.com/zitadel/zitadel (Go): affected from 4.0.0-rc.1; fixed in 4.7.1
- github.com/zitadel/zitadel (Go): affected from 4.0.0-rc.1; fixed in 4.7.1
- github.com/zitadel/zitadel/v2 (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251208091519-4c879b47334e
- github.com/zitadel/zitadel/v2 (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251208091519-4c879b47334e

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29067/ (Markdown: https://insights.sbomify.com/CVE-2026-29067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29067
- OSV: https://osv.dev/vulnerability/CVE-2026-29067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29067/
Summaries are generated and may contain mistakes; the official description above is the record.
