CVE-2026-29072 Discourse missing permission check for policy creation in discourse-policy
Unauthorized users can create policy acceptance widgets in posts, bypassing permission checks in the Discourse forum platform.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29072?
CVE-2026-29072 is a high-severity missing authorization vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, users who do not belong to the allowed policy creation groups can create functional policy acceptance widgets in posts under the right conditions. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, disable the discourse-policy plugin by disabling the `policy_enabled` site setting.
Weakness: CWE-862
Which versions are affected by CVE-2026-29072?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.4.0 |
Products include Discourse Discourse.
How do I fix CVE-2026-29072?
Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.4.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-29072 being exploited?
There is no known exploitation of CVE-2026-29072 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-29072, GHSA-7ph8-vprq-4jrp.