# CVE-2026-29077: Frappe: Broken Access Control in DocShare

> Attackers can share documents with permissions they do not possess, leading to unauthorized access and privilege escalation in Frappe applications.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-5h4c-9p23-4c3m

## What is CVE-2026-29077?

CVE-2026-29077 is a high-severity missing authorization vulnerability in frappe, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to versions 15.98.0 and 14.100.0, due to a lack of validation when sharing documents, a user could share a document with a permission that they themselves didn't have. This issue has been patched in versions 15.98.0 and 14.100.0.

Weakness: CWE-602 (Client-Side Enforcement of Server-Side Security), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-29077?

It affects 1 product.


Products: Frappe Frappe.

## How do I fix CVE-2026-29077?

No fix has been published for CVE-2026-29077 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-29077 being exploited?

There is no known exploitation of CVE-2026-29077 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29077 and fix it if it is affected.

What it is: CVE-2026-29077 is a high-severity missing authorization vulnerability in frappe, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29077 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29077/ (Markdown: https://insights.sbomify.com/CVE-2026-29077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29077
- OSV: https://osv.dev/vulnerability/CVE-2026-29077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29077/
Summaries are generated and may contain mistakes; the official description above is the record.
