# CVE-2026-29079: Type Confusion in Lexbor Fragment Parser

> A type confusion flaw in the Lexbor HTML fragment parser allows attackers to corrupt memory and potentially execute arbitrary code or cause a crash.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-29079, GHSA-mrpr-v36q-2vp8, UBUNTU-CVE-2026-29079

## What is CVE-2026-29079?

CVE-2026-29079 is a high-severity memory corruption vulnerability in lexbor, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lexbor is a web browser engine library. Prior to 2.7.0, a type‑confusion vulnerability exists in Lexbor’s HTML fragment parser. When ns = UNDEF, a comment is created using the “unknown element” constructor. The comment’s data are written into the element’s fields via an unsafe cast, corrupting the qualified_name field. That corrupted value is later used as a pointer and dereferenced near the zero page. This vulnerability is fixed in 2.7.0.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2026-29079?

It affects 1 product.


Products: Lexbor Lexbor.

## How do I fix CVE-2026-29079?

Upgrade to a fixed version.

## Is CVE-2026-29079 being exploited?

There is no known exploitation of CVE-2026-29079 in the wild and no public exploit code.

## Other vulnerabilities in lexbor

- [CVE-2026-29078](https://insights.sbomify.com/CVE-2026-29078/): Integer Underflow in Lexbor ISO‑2022‑JP Encoder (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29079 and fix it if it is affected.

What it is: CVE-2026-29079 is a high-severity memory corruption vulnerability in lexbor, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29079 in the wild and no public exploit code.

Affected product: lexbor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29079/ (Markdown: https://insights.sbomify.com/CVE-2026-29079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29079
- OSV: https://osv.dev/vulnerability/CVE-2026-29079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29079/
Summaries are generated and may contain mistakes; the official description above is the record.
