CVE-2026-29080 Rucio SQL Injection in FilterEngine Oracle JSON Path via DID Search API
Authenticated users can execute arbitrary SQL on Oracle deployments via the DID search API, exposing sensitive data and allowing database modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29080?
CVE-2026-29080 is a critical SQL injection vulnerability in rucio, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A SQL injection vulnerability in `FilterEngine.create_sqla_query()` allows any authenticated Rucio user to execute arbitrary SQL against the backend database through the DID search endpoint (`GET /dids/<scope>/dids/search`). On Oracle deployments attacker-controlled filter keys and values are interpolated directly into `sqlalchemy.text()` via Python `.format()`, completely bypassing parameterization. This enables full database compromise including extraction of authentication tokens, password hashes, and all managed data identifiers. This affects versions 1.27.0 and later before 35.8.5, 38.5.5, 39.4.2, and 40.1.1.
The vulnerability exists in `lib/rucio/core/did_meta_plugins/filter_engine.py` within the `create_sqla_query()` method. When the database dialect is Oracle, filter expressions for JSON metadata columns are constructed using `text()` with Python string formatting. Both `key` and `value` are attacker-controlled strings derived from HTTP query parameters. The `text()` function creates a raw SQL fragment — it does **not** escape or parameterize its contents.
Any authenticated Rucio user can exploit this through the DID search API to execute arbitrary SQL against the backend database. This can expose all managed data identifiers and sensitive tables such as identities, tokens, accounts, rse_settings, and rules, and may allow modification of database contents. The issue affects Oracle deployments using the default json_meta plugin and does not affect PostgreSQL or MySQL deployments using that plugin.
This vulnerability has been fixed in versions 35.8.5, 38.5.5, 39.4.2, and 40.1.1.
Weakness: CWE-89
Which versions are affected by CVE-2026-29080?
9 open source packages ship an affected version, including rucio. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rucio PyPI | From 1.27.0 | 35.8.5, 38.5.5, 39.4.2, 40.1.1 |
rucio PyPI | From 1.27.0 | 35.8.5 |
rucio PyPI | From 1.27.0 | 35.8.5 |
rucio PyPI | From 36.0.0 | 38.5.5 |
rucio PyPI | From 36.0.0 | 38.5.5 |
rucio PyPI | From 39.0.0 | 39.4.2 |
3 more packages
rucio PyPI | From 39.0.0 | 39.4.2 |
rucio PyPI | From 40.0.0 | 40.1.1 |
rucio PyPI | From 40.0.0 | 40.1.1 |
Products include Cern Rucio.
How do I fix CVE-2026-29080?
Upgrade rucio to a fixed version for your release line: 35.8.5, 38.5.5, 39.4.2 or 40.1.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-29080 being exploited?
There is no known exploitation of CVE-2026-29080 in the wild and no public exploit code.
Other vulnerabilities in rucio
- CVE-2026-29090 Rucio SQL injection in postgres_meta DID search path compromises PostgreSQL metadata database
- CVE-2026-25136 Rucio WebUI has a Reflected Cross-site Scripting Vulnerability
- CVE-2026-25733 Rucio WebUI Vulnerable to Stored Cross-site Scripting (XSS) through Custom Rule Function
- CVE-2026-25734 Rucio WebUI has Stored Cross-site Scripting (XSS) in RSE Metadata
- CVE-2026-25735 Rucio WebUI has a Stored Cross-site Scripting (XSS) vulnerability its Identity Name
Sources
Also known as GHSA-vjr5-c9qv-hgm3, PYSEC-2026-528.