# CVE-2026-29080: Rucio SQL Injection in FilterEngine Oracle JSON Path via DID Search API

> Authenticated users can execute arbitrary SQL on Oracle deployments via the DID search API, exposing sensitive data and allowing database modification.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-vjr5-c9qv-hgm3, PYSEC-2026-528

## What is CVE-2026-29080?

CVE-2026-29080 is a critical SQL injection vulnerability in rucio, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A SQL injection vulnerability in `FilterEngine.create_sqla_query()` allows any authenticated Rucio user to execute arbitrary SQL against the backend database through the DID search endpoint (`GET /dids/<scope>/dids/search`). On Oracle deployments attacker-controlled filter keys and values are interpolated directly into `sqlalchemy.text()` via Python `.format()`, completely bypassing parameterization. This enables full database compromise including extraction of authentication tokens, password hashes, and all managed data identifiers. This affects versions 1.27.0 and later before 35.8.5, 38.5.5, 39.4.2, and 40.1.1.

The vulnerability exists in `lib/rucio/core/did_meta_plugins/filter_engine.py` within the `create_sqla_query()` method. When the database dialect is Oracle, filter expressions for JSON metadata columns are constructed using `text()` with Python string formatting. Both `key` and `value` are attacker-controlled strings derived from HTTP query parameters. The `text()` function creates a raw SQL fragment — it does **not** escape or parameterize its contents.

Any authenticated Rucio user can exploit this through the DID search API to execute arbitrary SQL against the backend database. This can expose all managed data identifiers and sensitive tables such as identities, tokens, accounts, rse_settings, and rules, and may allow modification of database contents. The issue affects Oracle deployments using the default json_meta plugin and does not affect PostgreSQL or MySQL deployments using that plugin. 

This vulnerability has been fixed in versions 35.8.5, 38.5.5, 39.4.2, and 40.1.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-29080?

9 open source packages ship an affected version, including rucio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rucio` | PyPI | From 1.27.0 | 35.8.5, 38.5.5, 39.4.2, 40.1.1 |
| `rucio` | PyPI | From 1.27.0 | 35.8.5 |
| `rucio` | PyPI | From 1.27.0 | 35.8.5 |
| `rucio` | PyPI | From 36.0.0 | 38.5.5 |
| `rucio` | PyPI | From 36.0.0 | 38.5.5 |
| `rucio` | PyPI | From 39.0.0 | 39.4.2 |
| `rucio` | PyPI | From 39.0.0 | 39.4.2 |
| `rucio` | PyPI | From 40.0.0 | 40.1.1 |
| `rucio` | PyPI | From 40.0.0 | 40.1.1 |

Products: Cern Rucio.

## How do I fix CVE-2026-29080?

Upgrade rucio to a fixed version for your release line: 35.8.5, 38.5.5, 39.4.2 or 40.1.1.

## Is CVE-2026-29080 being exploited?

There is no known exploitation of CVE-2026-29080 in the wild and no public exploit code.

## Other vulnerabilities in rucio

- [CVE-2026-29090](https://insights.sbomify.com/CVE-2026-29090/): Rucio SQL injection in postgres_meta DID search path compromises PostgreSQL metadata database (critical 9.0)
- [CVE-2026-25136](https://insights.sbomify.com/CVE-2026-25136/): Rucio WebUI has a Reflected Cross-site Scripting Vulnerability (high 8.1)
- [CVE-2026-25733](https://insights.sbomify.com/CVE-2026-25733/): Rucio WebUI Vulnerable to Stored Cross-site Scripting (XSS) through Custom Rule Function (high 7.3)
- [CVE-2026-25734](https://insights.sbomify.com/CVE-2026-25734/): Rucio WebUI has Stored Cross-site Scripting (XSS) in RSE Metadata (medium 6.1)
- [CVE-2026-25735](https://insights.sbomify.com/CVE-2026-25735/): Rucio WebUI has a Stored Cross-site Scripting (XSS) vulnerability its Identity Name (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29080 and fix it if it is affected.

What it is: CVE-2026-29080 is a critical SQL injection vulnerability in rucio, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29080 in the wild and no public exploit code.

Affected packages and fixed versions:
- rucio (PyPI): affected from 1.27.0; fixed in 35.8.5, 38.5.5, 39.4.2, 40.1.1
- rucio (PyPI): affected from 1.27.0; fixed in 35.8.5
- rucio (PyPI): affected from 1.27.0; fixed in 35.8.5
- rucio (PyPI): affected from 36.0.0; fixed in 38.5.5
- rucio (PyPI): affected from 36.0.0; fixed in 38.5.5
- rucio (PyPI): affected from 39.0.0; fixed in 39.4.2
- rucio (PyPI): affected from 39.0.0; fixed in 39.4.2
- rucio (PyPI): affected from 40.0.0; fixed in 40.1.1
- rucio (PyPI): affected from 40.0.0; fixed in 40.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29080/ (Markdown: https://insights.sbomify.com/CVE-2026-29080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29080
- OSV: https://osv.dev/vulnerability/CVE-2026-29080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29080/
Summaries are generated and may contain mistakes; the official description above is the record.
