# CVE-2026-29081: Frappe: Possibility of SQL Injection due to improper fieldname sanitization

> Attackers can exploit improper fieldname sanitization in Frappe to perform SQL injection and extract sensitive information.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-w3g7-m7xr-2w38

## What is CVE-2026-29081?

CVE-2026-29081 is a medium-severity SQL injection vulnerability in frappe, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to versions 14.100.1 and 15.100.0, an endpoint was vulnerable to SQL injection through specially crafted requests, which would allow a malicious actor to extract sensitive information. This issue has been patched in versions 14.100.1 and 15.100.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-29081?

It affects 1 product.


Products: Frappe Frappe.

## How do I fix CVE-2026-29081?

No fix has been published for CVE-2026-29081 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-29081 being exploited?

There is no known exploitation of CVE-2026-29081 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29081 and fix it if it is affected.

What it is: CVE-2026-29081 is a medium-severity SQL injection vulnerability in frappe, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29081 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29081/ (Markdown: https://insights.sbomify.com/CVE-2026-29081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29081
- OSV: https://osv.dev/vulnerability/CVE-2026-29081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29081/
Summaries are generated and may contain mistakes; the official description above is the record.
