{"answers":{"affected":"2 open source packages ship an affected version, including @hono/node-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-29087 in the wild and no public exploit code.","fix":"Upgrade @hono/node-server to 1.19.10 or later.","what":"CVE-2026-29087 is a high-severity authentication bypass vulnerability in honojs node-server, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29087 and fix it if it is affected.\n\nWhat it is: CVE-2026-29087 is a high-severity authentication bypass vulnerability in honojs node-server, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-29087 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hono/node-server (npm): affected all versions; fixed in 1.19.10\n- @hono/node-server (npm): affected all versions; fixed in 1.19.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29087/ (Markdown: https://insights.sbomify.com/CVE-2026-29087/index.md)","id":"CVE-2026-29087","markdown":"https://insights.sbomify.com/CVE-2026-29087/index.md","name":"CVE-2026-29087","record":{"aliases":["CLEANSTART-2026-DD25783","CLEANSTART-2026-JJ09518","CLSA-2026-1793207049","GHSA-wc8c-qw6v-h7f6","MINI-5wh8-w6hm-pgxm","MINI-gg79-r5mh-4jxx","MINI-h939-8rq6-rcfq","MINI-h9mr-4m7v-g986","MINI-hrvj-8m3g-5v4c","MINI-jxjw-9mjv-p9q7","MINI-mx52-3ghw-cc9r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"Attackers can bypass authorization checks on protected static files by using encoded slashes, allowing unauthorized access to sensitive resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"node-server","vendor":"hono"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"@hono/node-server allows running the Hono application on Node.js. Prior to version 1.19.10, when using @hono/node-server's static file serving together with route-based middleware protections (e.g. protecting /admin/*), inconsistent URL decoding can allow protected static resources to be accessed without authorization. In particular, paths containing encoded slashes (%2F) may be evaluated differently by routing/middleware matching versus static file path resolution, enabling a bypass where middleware does not run but the static file is still served. This issue has been patched in version 1.19.10.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@hono/node-server: Authorization bypass for protected static paths via encoded slashes in Serve Static Middleware","id":"CVE-2026-29087","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"TimescaleDB uses untrusted search path during extension upgrade","id":"CVE-2026-29089"},"packages":[{"ecosystem":"npm","fixed":["1.19.10"],"introduced":["0"],"last_affected":[],"package":"@hono/node-server","purl":null,"source":"GHSA-wc8c-qw6v-h7f6"},{"ecosystem":"npm","fixed":["1.19.10"],"introduced":["0"],"last_affected":[],"package":"@hono/node-server","purl":"pkg:npm/%40hono/node-server","source":"GHSA-wc8c-qw6v-h7f6"}],"prev":{"headline":"Hono: Cookie Attribute Injection via Unsanitized domain and path in setCookie()","id":"CVE-2026-29086"},"products":["node-server"],"published":"2026-03-06","related":[{"cvss_score":7.5,"headline":"@hono/node-server contains Denial of Service risk when receiving Host header that cannot be parsed","id":"CVE-2024-32652","kev_date_added":null,"published":"2024-04-19"},{"cvss_score":5.3,"headline":"@hono/node-server has a middleware bypass via repeated slashes in serveStatic","id":"CVE-2026-39406","kev_date_added":null,"published":"2026-04-08"},{"cvss_score":5.3,"headline":"@hono/node-server can't handle \"double dots\" in URL","id":"CVE-2024-23340","kev_date_added":null,"published":"2024-01-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-06","vendors":["honojs"]},"summary":"Attackers can bypass authorization checks on protected static files by using encoded slashes, allowing unauthorized access to sensitive resources.","url":"https://insights.sbomify.com/CVE-2026-29087/"}