# CVE-2026-29087: @hono/node-server: Authorization bypass for protected static paths via encoded slashes in Serve Static Middleware

> Attackers can bypass authorization checks on protected static files by using encoded slashes, allowing unauthorized access to sensitive resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** CLEANSTART-2026-DD25783, CLEANSTART-2026-JJ09518, CLSA-2026-1793207049, GHSA-wc8c-qw6v-h7f6, MINI-5wh8-w6hm-pgxm, MINI-gg79-r5mh-4jxx, MINI-h939-8rq6-rcfq, MINI-h9mr-4m7v-g986, MINI-hrvj-8m3g-5v4c, MINI-jxjw-9mjv-p9q7, MINI-mx52-3ghw-cc9r

## What is CVE-2026-29087?

CVE-2026-29087 is a high-severity authentication bypass vulnerability in honojs node-server, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@hono/node-server allows running the Hono application on Node.js. Prior to version 1.19.10, when using @hono/node-server's static file serving together with route-based middleware protections (e.g. protecting /admin/*), inconsistent URL decoding can allow protected static resources to be accessed without authorization. In particular, paths containing encoded slashes (%2F) may be evaluated differently by routing/middleware matching versus static file path resolution, enabling a bypass where middleware does not run but the static file is still served. This issue has been patched in version 1.19.10.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-29087?

2 open source packages ship an affected version, including @hono/node-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hono/node-server` | npm | All versions | 1.19.10 |
| `@hono/node-server` | npm | All versions | 1.19.10 |

Products: Hono Node-Server.

## How do I fix CVE-2026-29087?

Upgrade @hono/node-server to 1.19.10 or later.

## Is CVE-2026-29087 being exploited?

There is no known exploitation of CVE-2026-29087 in the wild and no public exploit code.

## Other vulnerabilities in honojs node-server

- [CVE-2024-32652](https://insights.sbomify.com/CVE-2024-32652/): @hono/node-server contains Denial of Service risk when receiving Host header that cannot be parsed (high 7.5)
- [CVE-2026-39406](https://insights.sbomify.com/CVE-2026-39406/): @hono/node-server has a middleware bypass via repeated slashes in serveStatic (medium 5.3)
- [CVE-2024-23340](https://insights.sbomify.com/CVE-2024-23340/): @hono/node-server can't handle "double dots" in URL (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29087 and fix it if it is affected.

What it is: CVE-2026-29087 is a high-severity authentication bypass vulnerability in honojs node-server, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29087 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hono/node-server (npm): affected all versions; fixed in 1.19.10
- @hono/node-server (npm): affected all versions; fixed in 1.19.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29087/ (Markdown: https://insights.sbomify.com/CVE-2026-29087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29087
- OSV: https://osv.dev/vulnerability/CVE-2026-29087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29087/
Summaries are generated and may contain mistakes; the official description above is the record.
