{"answers":{"affected":"2 open source packages ship an affected version, including locutus. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29091 exists.","fix":"Upgrade locutus to 3.0.0 or later.","what":"CVE-2026-29091 is a high-severity code injection vulnerability in locutusjs locutus, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29091 and fix it if it is affected.\n\nWhat it is: CVE-2026-29091 is a high-severity code injection vulnerability in locutusjs locutus, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29091 exists.\n\nAffected packages and fixed versions:\n- locutus (npm): affected all versions; fixed in 3.0.0\n- locutus (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29091/ (Markdown: https://insights.sbomify.com/CVE-2026-29091/index.md)","id":"CVE-2026-29091","markdown":"https://insights.sbomify.com/CVE-2026-29091/index.md","name":"CVE-2026-29091","record":{"aliases":["GHSA-fp25-p6mj-qqg6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript stdlib library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript code via the call_user_func_array function in the Locutus library due to insecure eval usage.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"locutus","vendor":"locutus"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"Locutus brings stdlibs of other programming languages to JavaScript for educational purposes. Prior to version 3.0.0, a remote code execution (RCE) flaw was discovered in the locutus project, specifically within the call_user_func_array function implementation. The vulnerability allows an attacker to inject arbitrary JavaScript code into the application's runtime environment. This issue stems from an insecure implementation of the call_user_func_array function (and its wrapper call_user_func), which fails to properly validate all components of a callback array before passing them to eval(). This issue has been patched in version 3.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Locutus: Remote Code Execution (RCE) in locutus call_user_func_array due to Code Injection","id":"CVE-2026-29091","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Kiteworks Email Protection Gateway has an Insufficient Session Expiration","id":"CVE-2026-29092"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"locutus","purl":null,"source":"GHSA-fp25-p6mj-qqg6"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"locutus","purl":"pkg:npm/locutus","source":"GHSA-fp25-p6mj-qqg6"}],"prev":{"headline":"Rucio SQL injection in postgres_meta DID search path compromises PostgreSQL metadata database","id":"CVE-2026-29090"},"products":["locutus"],"published":"2026-03-06","related":[{"cvss_score":9.8,"headline":"Locutus: RCE via unsanitized input in create_function()","id":"CVE-2026-32304","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":9.8,"headline":"Prototype Pollution","id":"CVE-2020-7719","kev_date_added":null,"published":"2020-09-01"},{"cvss_score":9.4,"headline":"Locutus is vulnerable to Prototype Pollution","id":"CVE-2026-25521","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":6.9,"headline":"Locutus has Prototype Pollution via __proto__ Key Injection in unserialize()","id":"CVE-2026-33993","kev_date_added":null,"published":"2026-03-27"},{"cvss_score":6.3,"headline":"Locutus Prototype Pollution due to incomplete fix for CVE-2026-25521","id":"CVE-2026-33994","kev_date_added":null,"published":"2026-03-27"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23392","kev_date_added":null,"published":"2021-06-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["locutusjs"]},"summary":"Attackers can execute arbitrary JavaScript code via the call_user_func_array function in the Locutus library due to insecure eval usage.","url":"https://insights.sbomify.com/CVE-2026-29091/"}