# CVE-2026-29112: @dicebear/converter vulnerable to ncontrolled memory allocation via crafted SVG dimensions

> An attacker can cause denial of service by supplying crafted SVGs with excessive dimensions to the DiceBear converter, forcing excessive memory allocation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-v3r3-4qgc-vw66

## What is CVE-2026-29112?

CVE-2026-29112 is a high-severity denial of service vulnerability in dicebear, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DiceBear is an avatar library for designers and developers. Prior to version 9.4.0, the `ensureSize()` function in `@dicebear/converter` read the `width` and `height` attributes from the input SVG to determine the output canvas size for rasterization (PNG, JPEG, WebP, AVIF). An attacker who can supply a crafted SVG with extremely large dimensions (e.g. `width="999999999"`) could force the server to allocate excessive memory, leading to denial of service. This primarily affects server-side applications that pass untrusted or user-supplied SVGs to the converter's `toPng()`, `toJpeg()`, `toWebp()`, or `toAvif()` functions. Applications that only convert self-generated DiceBear avatars are not practically exploitable, but are still recommended to upgrade. This is fixed in version 9.4.0. The `ensureSize()` function no longer reads SVG attributes to determine output size. Instead, a new `size` option (default: 512, max: 2048) controls the output dimensions. Invalid values (NaN, negative, zero, Infinity) fall back to the default. If upgrading is not immediately possible, validate and sanitize the `width` and `height` attributes of any untrusted SVG input before passing it to the converter.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-29112?

2 open source packages ship an affected version, including @dicebear/converter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dicebear/converter` | npm | All versions | 9.4.0 |
| `@dicebear/converter` | npm | All versions | 9.4.0 |

Products: Dicebear Dicebear.

## How do I fix CVE-2026-29112?

Upgrade @dicebear/converter to 9.4.0 or later.

## Is CVE-2026-29112 being exploited?

There is no known exploitation of CVE-2026-29112 in the wild and no public exploit code.

## Other vulnerabilities in dicebear

- [CVE-2026-33418](https://insights.sbomify.com/CVE-2026-33418/): @dicebear/converter ensureSize() Vulnerable to SVG Dimension Capping Bypass via XML Comment Injection (high 7.5)
- [CVE-2026-33311](https://insights.sbomify.com/CVE-2026-33311/): @dicebear/core and @dicebear/initials Vulnerable to SVG Injection via Unsanitized Options (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29112 and fix it if it is affected.

What it is: CVE-2026-29112 is a high-severity denial of service vulnerability in dicebear, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29112 in the wild and no public exploit code.

Affected packages and fixed versions:
- @dicebear/converter (npm): affected all versions; fixed in 9.4.0
- @dicebear/converter (npm): affected all versions; fixed in 9.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29112/ (Markdown: https://insights.sbomify.com/CVE-2026-29112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29112
- OSV: https://osv.dev/vulnerability/CVE-2026-29112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29112/
Summaries are generated and may contain mistakes; the official description above is the record.
