CVE-2026-29113 Craft has a potential information disclosure vulnerability in preview tokens
Attackers can force logged-in editors to generate attacker-controlled preview tokens, allowing unauthorized access to unpublished content.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-29113?
CVE-2026-29113 is a low-severity vulnerability in Craftcms Craft Cms, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Craft is a content management system (CMS). Prior to 4.17.3 and 5.9.7, Craft CMS has a CSRF issue in the preview token endpoint at /actions/preview/create-token. The endpoint accepts an attacker-supplied previewToken. Because the action does not require POST and does not enforce a CSRF token, an attacker can force a logged-in victim editor to mint a preview token chosen by the attacker. That token can then be used by the attacker (without authentication) to access previewed/unpublished content tied to the victim’s authorized preview scope. This vulnerability is fixed in 4.17.3 and 5.9.7.
Weakness: CWE-352
Which versions are affected by CVE-2026-29113?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.3 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.3 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.7 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.7 |
Products include Craftcms Craft Cms.
How do I fix CVE-2026-29113?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.3 or 5.9.7.
Is CVE-2026-29113 being exploited?
There is no known exploitation of CVE-2026-29113 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-vg3j-hpm9-8v5v.