# CVE-2026-29113: Craft has a potential information disclosure vulnerability in preview tokens

> Attackers can force logged-in editors to generate attacker-controlled preview tokens, allowing unauthorized access to unpublished content.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 2 Sep 2026
- **Also known as:** GHSA-vg3j-hpm9-8v5v

## What is CVE-2026-29113?

CVE-2026-29113 is a low-severity vulnerability in Craftcms Craft Cms, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Craft is a content management system (CMS). Prior to 4.17.3 and 5.9.7, Craft CMS has a CSRF issue in the preview token endpoint at /actions/preview/create-token. The endpoint accepts an attacker-supplied previewToken. Because the action does not require POST and does not enforce a CSRF token, an attacker can force a logged-in victim editor to mint a preview token chosen by the attacker. That token can then be used by the attacker (without authentication) to access previewed/unpublished content tied to the victim’s authorized preview scope. This vulnerability is fixed in 4.17.3 and 5.9.7.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-29113?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.3 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.3 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.7 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.7 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-29113?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.3 or 5.9.7.

## Is CVE-2026-29113 being exploited?

There is no known exploitation of CVE-2026-29113 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29113 and fix it if it is affected.

What it is: CVE-2026-29113 is a low-severity vulnerability in Craftcms Craft Cms, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29113 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.3
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.3
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.7
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29113/ (Markdown: https://insights.sbomify.com/CVE-2026-29113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29113
- OSV: https://osv.dev/vulnerability/CVE-2026-29113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29113/
Summaries are generated and may contain mistakes; the official description above is the record.
