CVE-2026-29129 Apache Tomcat: TLS cipher order is not preserved
Apache Tomcat fails to preserve configured TLS cipher preference order, potentially weakening encryption security.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29129?
CVE-2026-29129 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Configured cipher preference order not preserved vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115.
Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
Weakness: CWE-327
Which versions are affected by CVE-2026-29129?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.51 | 10.1.53 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.51 | 10.1.53 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.16 | 11.0.20 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.16 | 11.0.20 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.114 | 9.0.116 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.114 | 9.0.116 |
13 more packages
tomcat Bitnami | From 9.0.114 | 9.0.116, 10.1.53, 11.0.20 |
org.apache.tomcat:tomcat Maven | From 10.1.51 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 10.1.51 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 11.0.16 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 11.0.16 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 9.0.114 | 9.0.116 |
org.apache.tomcat:tomcat Maven | From 9.0.114 | 9.0.116 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.51 | 10.1.53 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.51 | 10.1.53 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.16 | 11.0.20 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.16 | 11.0.20 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.114 | 9.0.116 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.114 | 9.0.116 |
Products include Apache Tomcat.
How do I fix CVE-2026-29129?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.
Is CVE-2026-29129 being exploited?
There is no known exploitation of CVE-2026-29129 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-29129, DEBIAN-CVE-2026-29129, GHSA-69cc-cv78-qc8g, MINI-7p6r-v2x3-9vf2, MINI-hw5v-388h-pg2x, MINI-wv3g-57qq-jj42 and 2 more.