# CVE-2026-29129: Apache Tomcat: TLS cipher order is not preserved

> Apache Tomcat fails to preserve configured TLS cipher preference order, potentially weakening encryption security.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** BIT-tomcat-2026-29129, DEBIAN-CVE-2026-29129, GHSA-69cc-cv78-qc8g, MINI-7p6r-v2x3-9vf2, MINI-hw5v-388h-pg2x, MINI-wv3g-57qq-jj42, ROOT-APP-MAVEN-CVE-2026-29129, UBUNTU-CVE-2026-29129

## What is CVE-2026-29129?

CVE-2026-29129 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Configured cipher preference order not preserved vulnerability in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115.

Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2026-29129?

19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.51 | 10.1.53 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.51 | 10.1.53 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.16 | 11.0.20 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.16 | 11.0.20 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.114 | 9.0.116 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.114 | 9.0.116 |
| `tomcat` | Bitnami | From 9.0.114 | 9.0.116, 10.1.53, 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.51 | 10.1.53 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.51 | 10.1.53 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.16 | 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.16 | 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.114 | 9.0.116 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.114 | 9.0.116 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.51 | 10.1.53 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.51 | 10.1.53 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.16 | 11.0.20 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.16 | 11.0.20 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.114 | 9.0.116 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.114 | 9.0.116 |

Products: Apache Tomcat.

## How do I fix CVE-2026-29129?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.

## Is CVE-2026-29129 being exploited?

There is no known exploitation of CVE-2026-29129 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29129 and fix it if it is affected.

What it is: CVE-2026-29129 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29129 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.51; fixed in 10.1.53
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.51; fixed in 10.1.53
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.16; fixed in 11.0.20
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.16; fixed in 11.0.20
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.114; fixed in 9.0.116
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.114; fixed in 9.0.116
- tomcat (Bitnami): affected from 9.0.114; fixed in 9.0.116, 10.1.53, 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 10.1.51; fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): affected from 10.1.51; fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): affected from 11.0.16; fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 11.0.16; fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 9.0.114; fixed in 9.0.116

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29129/ (Markdown: https://insights.sbomify.com/CVE-2026-29129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29129
- OSV: https://osv.dev/vulnerability/CVE-2026-29129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29129/
Summaries are generated and may contain mistakes; the official description above is the record.
