CVE-2026-29145 Apache Tomcat, Apache Tomcat Native: OCSP checks sometimes soft-fail even when soft-fail is disabled
Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29145?
CVE-2026-29145 is a critical authentication bypass vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13.
Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.
Weakness: CWE-287
Which versions are affected by CVE-2026-29145?
13 open source packages ship an affected version, including org.apache.tomcat:tomcat, tomcat and org.apache.tomcat:tomcat-coyote-ffm. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 10.1.0-M7 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M7 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 9.0.83 | 9.0.116 |
org.apache.tomcat:tomcat Maven | From 9.0.83 | 9.0.116 |
7 more packages
tomcat Bitnami | All versions | 8.5.98, 9.0.116, 10.1.53, 11.0.20 |
org.apache.tomcat:tomcat-coyote-ffm Maven | From 10.1.0-M7 | 10.1.53 |
org.apache.tomcat:tomcat-coyote-ffm Maven | From 10.1.0-M7 | 10.1.53 |
org.apache.tomcat:tomcat-coyote-ffm Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat-coyote-ffm Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat-coyote-ffm Maven | From 9.0.83 | 9.0.116 |
org.apache.tomcat:tomcat-coyote-ffm Maven | From 9.0.83 | 9.0.116 |
Products include Apache Tomcat, Apache Tomcat Native.
How do I fix CVE-2026-29145?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-29145 being exploited?
There is no known exploitation of CVE-2026-29145 in the wild and no public exploit code.
Public exploit code: 4 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-29145, CLEANSTART-2026-CQ07161, DEBIAN-CVE-2026-29145, GHSA-95jq-rwvf-vjx4, ROOT-APP-MAVEN-CVE-2026-29145, UBUNTU-CVE-2026-29145.