# CVE-2026-29145: Apache Tomcat, Apache Tomcat Native: OCSP checks sometimes soft-fail even when soft-fail is disabled

> Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled, allowing unauthorized access.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** BIT-tomcat-2026-29145, CLEANSTART-2026-CQ07161, DEBIAN-CVE-2026-29145, GHSA-95jq-rwvf-vjx4, ROOT-APP-MAVEN-CVE-2026-29145, UBUNTU-CVE-2026-29145

## What is CVE-2026-29145?

CVE-2026-29145 is a critical authentication bypass vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13.

Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-29145?

13 open source packages ship an affected version, including org.apache.tomcat:tomcat, tomcat and org.apache.tomcat:tomcat-coyote-ffm. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M7 | 10.1.53 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M7 | 10.1.53 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.83 | 9.0.116 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.83 | 9.0.116 |
| `tomcat` | Bitnami | All versions | 8.5.98, 9.0.116, 10.1.53, 11.0.20 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 10.1.0-M7 | 10.1.53 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 10.1.0-M7 | 10.1.53 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 9.0.83 | 9.0.116 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 9.0.83 | 9.0.116 |

Products: Apache Tomcat, Apache Tomcat Native.

## How do I fix CVE-2026-29145?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.

## Is CVE-2026-29145 being exploited?

There is no known exploitation of CVE-2026-29145 in the wild and no public exploit code.

Public exploit code:

- https://github.com/gregk4sec/cve-2026-29145 (github_poc): https://github.com/gregk4sec/cve-2026-29145
- https://github.com/gkdgkd123/CVE-2026-29145-Everything (github_poc): https://github.com/gkdgkd123/CVE-2026-29145-Everything
- This repository contains a proof-of-concept (PoC) environment designed to test for CVE-2026-29145. (github_poc): https://github.com/sancliffe/CVE-2026-29145-Tester
- This repository contains a proof-of-concept (PoC) environment designed to test for CVE-2026-29145. (github_poc): https://github.com/Chenjp/CVE-2026-29145-Tester

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29145 and fix it if it is affected.

What it is: CVE-2026-29145 is a critical authentication bypass vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29145 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M7; fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M7; fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 9.0.83; fixed in 9.0.116
- org.apache.tomcat:tomcat (Maven): affected from 9.0.83; fixed in 9.0.116
- tomcat (Bitnami): affected all versions; fixed in 8.5.98, 9.0.116, 10.1.53, 11.0.20
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 10.1.0-M7; fixed in 10.1.53
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 10.1.0-M7; fixed in 10.1.53
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 11.0.0-M1; fixed in 11.0.20
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 11.0.0-M1; fixed in 11.0.20
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 9.0.83; fixed in 9.0.116

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29145/ (Markdown: https://insights.sbomify.com/CVE-2026-29145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29145
- OSV: https://osv.dev/vulnerability/CVE-2026-29145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29145/
Summaries are generated and may contain mistakes; the official description above is the record.
