CVE-2026-29146 Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default
Attackers can exploit a padding oracle vulnerability in Tomcat's EncryptInterceptor to decrypt sensitive data or bypass security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29146?
CVE-2026-29146 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.
Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.
Which versions are affected by CVE-2026-29146?
21 open source packages ship an affected version, including org.apache.tomcat:tomcat, tomcat and org.apache.tomcat:tomcat-tribes. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 7.0.100 to 7.0.109 | None |
org.apache.tomcat:tomcat Maven | From 7.0.100 to 7.0.109 | None |
15 more packages
org.apache.tomcat:tomcat Maven | From 8.5.38 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 8.5.38 to 8.5.100 | None |
org.apache.tomcat:tomcat Maven | From 9.0.13 | 9.0.116 |
org.apache.tomcat:tomcat Maven | From 9.0.13 | 9.0.116 |
tomcat Bitnami | From 7.0.100 | 9.0.116, 10.1.53, 11.0.19 |
org.apache.tomcat:tomcat-tribes Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat-tribes Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat-tribes Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat-tribes Maven | From 11.0.0-M1 | 11.0.20 |
org.apache.tomcat:tomcat-tribes Maven | From 7.0.100 to 7.0.109 | None |
org.apache.tomcat:tomcat-tribes Maven | From 7.0.100 to 7.0.109 | None |
org.apache.tomcat:tomcat-tribes Maven | From 8.5.38 to 8.5.100 | None |
org.apache.tomcat:tomcat-tribes Maven | From 8.5.38 to 8.5.100 | None |
org.apache.tomcat:tomcat-tribes Maven | From 9.0.13 | 9.0.116 |
org.apache.tomcat:tomcat-tribes Maven | From 9.0.13 | 9.0.116 |
Products include Apache Tomcat.
How do I fix CVE-2026-29146?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.
Is CVE-2026-29146 being exploited?
There is no known exploitation of CVE-2026-29146 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-29146, CLSA-2026-1776818221, CLSA-2026-1786484994, DEBIAN-CVE-2026-29146, GHSA-h468-7pvh-8vr8, UBUNTU-CVE-2026-29146.