# CVE-2026-29146: Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

> Attackers can exploit a padding oracle vulnerability in Tomcat's EncryptInterceptor to decrypt sensitive data or bypass security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 17 Aug 2026
- **Also known as:** BIT-tomcat-2026-29146, CLSA-2026-1776818221, CLSA-2026-1786484994, DEBIAN-CVE-2026-29146, GHSA-h468-7pvh-8vr8, UBUNTU-CVE-2026-29146

## What is CVE-2026-29146?

CVE-2026-29146 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Weakness: CWE-1240 (Use of a Cryptographic Primitive with a Risky Implementation), CWE-642 (External Control of Critical State Data), CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-29146?

21 open source packages ship an affected version, including org.apache.tomcat:tomcat, tomcat and org.apache.tomcat:tomcat-tribes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.50 | 10.1.53 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.50 | 10.1.53 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.100 to 7.0.109 | None |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.100 to 7.0.109 | None |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.38 to 8.5.100 | None |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.38 to 8.5.100 | None |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.13 | 9.0.116 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.13 | 9.0.116 |
| `tomcat` | Bitnami | From 7.0.100 | 9.0.116, 10.1.53, 11.0.19 |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 10.1.50 | 10.1.53 |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 10.1.50 | 10.1.53 |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 11.0.0-M1 | 11.0.20 |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 7.0.100 to 7.0.109 | None |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 7.0.100 to 7.0.109 | None |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 8.5.38 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 8.5.38 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 9.0.13 | 9.0.116 |
| `org.apache.tomcat:tomcat-tribes` | Maven | From 9.0.13 | 9.0.116 |

Products: Apache Tomcat.

## How do I fix CVE-2026-29146?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.

## Is CVE-2026-29146 being exploited?

There is no known exploitation of CVE-2026-29146 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29146 and fix it if it is affected.

What it is: CVE-2026-29146 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29146 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 10.1.50; fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): affected from 10.1.50; fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): affected from 7.0.100 up to 7.0.109; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 7.0.100 up to 7.0.109; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 8.5.38 up to 8.5.100; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 8.5.38 up to 8.5.100; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 9.0.13; fixed in 9.0.116
- org.apache.tomcat:tomcat (Maven): affected from 9.0.13; fixed in 9.0.116
- tomcat (Bitnami): affected from 7.0.100; fixed in 9.0.116, 10.1.53, 11.0.19
- org.apache.tomcat:tomcat-tribes (Maven): affected from 10.1.50; fixed in 10.1.53

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29146/ (Markdown: https://insights.sbomify.com/CVE-2026-29146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29146
- OSV: https://osv.dev/vulnerability/CVE-2026-29146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29146/
Summaries are generated and may contain mistakes; the official description above is the record.
