CVE-2026-29167 Apache HTTP Server: mod_ldap per-dir use-after-free
A use-after-free flaw in Apache HTTP Server's mod_ldap module allows attackers to potentially execute code or cause a denial of service when per-directory configurations are used.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29167?
CVE-2026-29167 is a critical use after free vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
Weakness: CWE-416
Which versions are affected by CVE-2026-29167?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.68 |
Linux distribution packages (39)
httpd AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
httpd-core AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
httpd-devel AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
httpd-filesystem AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
httpd-manual AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
httpd-tools AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
mod_ldap AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
mod_lua AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
mod_proxy_html AlmaLinux:10 | All versions | 1:2.4.63-13.el10_2.6 |
mod_session AlmaLinux:10 | All versions | 2.4.63-13.el10_2.6 |
mod_ssl AlmaLinux:10 | All versions | 1:2.4.63-13.el10_2.6 |
httpd AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
httpd-devel AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
httpd-filesystem AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
httpd-manual AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
httpd-tools AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
mod_http2 AlmaLinux:8 | All versions | 1.15.7-10.module_el8.10.0+4233+8b7d9181.7 |
mod_ldap AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
mod_md AlmaLinux:8 | All versions | 1:2.0.8-8.module_el8.10.0+4088+57f011c1.2 |
mod_proxy_html AlmaLinux:8 | All versions | 1:2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
mod_session AlmaLinux:8 | All versions | 2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
mod_ssl AlmaLinux:8 | All versions | 1:2.4.37-65.module_el8.10.0+4270+e5f13fdb.10 |
httpd AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
httpd-core AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
httpd-devel AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
httpd-filesystem AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
httpd-manual AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
httpd-tools AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
mod_ldap AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
mod_lua AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
mod_proxy_html AlmaLinux:9 | All versions | 1:2.4.62-13.el9_8.6 |
mod_session AlmaLinux:9 | All versions | 2.4.62-13.el9_8.6 |
mod_ssl AlmaLinux:9 | All versions | 1:2.4.62-13.el9_8.6 |
httpd Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.6 |
httpd-core Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.6 |
httpd-core-debuginfo Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.6 |
httpd-debuginfo Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.6 |
httpd-debugsource Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.6 |
httpd-devel Red Hat:enterprise_linux:10.2 | All versions | 0:2.4.63-13.el10_2.6 |
Products include Apache Http Server.
How do I fix CVE-2026-29167?
Upgrade apache to 2.4.68 or later.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2026-29167 being exploited?
There is no known exploitation of CVE-2026-29167 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALSA-2026:59347, ALSA-2026:60004, ALSA-2026:64794, AZL-89732, BELL-CVE-2026-29167, BIT-apache-2026-29167 and 11 more.