CVE-2026-29168 Apache HTTP Server: mod_md unrestricted OCSP response

High 7.3 Published Updated

An attacker can cause a denial of service in Apache HTTP Server by sending unrestricted OCSP response data to the mod_md module.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-29168?

CVE-2026-29168 is a high-severity denial of service vulnerability in Apache Http Server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Allocation of Resources Without Limits or Throttling vulnerability in Apache HTTP Server's  mod_md via OCSP response data.

This issue affects Apache HTTP Server: from 2.4.30 through 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-770

Which versions are affected by CVE-2026-29168?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.302.4.67
Linux distribution packages (25)
mod_md AlmaLinux:10All versions1:2.4.26-5.el10_2.1
mod_md AlmaLinux:9All versions1:2.4.26-2.el9_8.1
mod_md Red Hat:enterprise_linux:10.2All versions1:2.4.26-5.el10_2.1
mod_md-debuginfo Red Hat:enterprise_linux:10.2All versions1:2.4.26-5.el10_2.1
mod_md-debugsource Red Hat:enterprise_linux:10.2All versions1:2.4.26-5.el10_2.1
mod_md Red Hat:enterprise_linux:9::appstreamAll versions1:2.4.26-2.el9_8.1
mod_md-debuginfo Red Hat:enterprise_linux:9::appstreamAll versions1:2.4.26-2.el9_8.1
mod_md-debugsource Red Hat:enterprise_linux:9::appstreamAll versions1:2.4.26-2.el9_8.1
mod_md Red Hat:enterprise_linux_eus:10.0All versions1:2.4.26-3.el10_0.2
httpd Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
httpd-core Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
httpd-devel Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
httpd-filesystem Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
httpd-manual Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
httpd-tools Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
mod_ldap Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
mod_lua Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
mod_proxy_html Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
mod_session Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
mod_ssl Red Hat:hummingbird:1All versions0:2.4.68-6.hum1
mod_md Red Hat:rhel_e4s:9.2::appstreamAll versions1:2.4.19-1.el9_2.2
mod_md Red Hat:rhel_e4s:9.4::appstreamAll versions1:2.4.19-1.el9_4.2
mod_md Red Hat:rhel_eus:9.6::appstreamAll versions1:2.4.26-1.el9_6.2
mod_md Rocky Linux:10All versions1:2.4.26-5.el10_2.1
mod_md Rocky Linux:9All versions1:2.4.26-2.el9_8.1

Products include Apache Http Server.

How do I fix CVE-2026-29168?

Upgrade apache to 2.4.67 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-29168 being exploited?

There is no known exploitation of CVE-2026-29168 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-29168, ALSA-2026:30844, ALSA-2026:30845, AZL-85871, AZL-85995, BELL-CVE-2026-29168 and 17 more.

Is CVE-2026-29168 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free