CVE-2026-29169 Apache HTTP Server: mod_dav_lock indirect lock crash
A NULL pointer dereference in mod_dav_lock allows attackers to crash the Apache HTTP Server via malicious requests, requiring the module to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-29169?
CVE-2026-29169 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A NULL pointer dereference in mod_dav_lock in Apache HTTP Server 2.4.66 and earlier may allow an attacker to crash the server with a malicious request.mod_dav_lock is not used internally by mod_dav or mod_dav_fs.
The only known use-case for mod_dav_lock was mod_dav_svn from Apache Subversion earlier than version 1.2.0.
Users are recommended to upgrade to version 2.4.66, which fixes this issue, or remove mod_dav_lock.
Weakness: CWE-476
Which versions are affected by CVE-2026-29169?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | All versions | 2.4.67 |
Products include Apache Http Server.
How do I fix CVE-2026-29169?
Upgrade apache to 2.4.67 or later.
Is CVE-2026-29169 being exploited?
There is no known exploitation of CVE-2026-29169 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-29169, AZL-86019, BELL-CVE-2026-29169, BIT-apache-2026-29169, CLSA-2026-1782157735, CLSA-2026-1782159571 and 4 more.