# CVE-2026-29169: Apache HTTP Server: mod_dav_lock indirect lock crash

> A NULL pointer dereference in mod_dav_lock allows attackers to crash the Apache HTTP Server via malicious requests, requiring the module to be enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** ALPINE-CVE-2026-29169, AZL-86019, BELL-CVE-2026-29169, BIT-apache-2026-29169, CLSA-2026-1782157735, CLSA-2026-1782159571, CLSA-2026-1782295144, DEBIAN-CVE-2026-29169, GHSA-jmv5-rcpx-7f7r, MINI-hcch-qqxq-7m9v

## What is CVE-2026-29169?

CVE-2026-29169 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A NULL pointer dereference in mod_dav_lock in Apache HTTP Server 2.4.66 and earlier may allow an attacker to crash the server with a malicious request.mod_dav_lock is not used internally by mod_dav or mod_dav_fs.

The only known use-case for mod_dav_lock was mod_dav_svn from Apache Subversion earlier than version 1.2.0.

Users are recommended to upgrade to version 2.4.66, which fixes this issue, or remove mod_dav_lock.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-29169?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.67 |

Products: Apache Http Server.

## How do I fix CVE-2026-29169?

Upgrade apache to 2.4.67 or later.

## Is CVE-2026-29169 being exploited?

There is no known exploitation of CVE-2026-29169 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29169 and fix it if it is affected.

What it is: CVE-2026-29169 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29169 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.67

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29169/ (Markdown: https://insights.sbomify.com/CVE-2026-29169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29169
- OSV: https://osv.dev/vulnerability/CVE-2026-29169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29169/
Summaries are generated and may contain mistakes; the official description above is the record.
