CVE-2026-29170 Apache HTTP Server: mod_proxy_ftp XSS

Medium 6.1 Published Updated

Cross-site scripting in mod_proxy_ftp allows attackers to inject scripts when listing FTP directories, requiring proxy configuration.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-29170?

CVE-2026-29170 is a medium-severity cross-site scripting vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration.

Users are recommended to upgrade to version 2.4.68, which fixes this issue.

Weakness: CWE-79

Which versions are affected by CVE-2026-29170?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.68

Products include Apache Http Server.

How do I fix CVE-2026-29170?

Upgrade apache to 2.4.68 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-29170 being exploited?

There is no known exploitation of CVE-2026-29170 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-29170, AZL-89723, BELL-CVE-2026-29170, BIT-apache-2026-29170, DEBIAN-CVE-2026-29170, ECHO-22e1-03d3-bb43 and 3 more.

Is CVE-2026-29170 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free