# CVE-2026-29170: Apache HTTP Server: mod_proxy_ftp XSS

> Cross-site scripting in mod_proxy_ftp allows attackers to inject scripts when listing FTP directories, requiring proxy configuration.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** ALPINE-CVE-2026-29170, AZL-89723, BELL-CVE-2026-29170, BIT-apache-2026-29170, DEBIAN-CVE-2026-29170, ECHO-22e1-03d3-bb43, GHSA-9rm4-vpqg-mfpc, MINI-j9px-8w57-jcp9, UBUNTU-CVE-2026-29170

## What is CVE-2026-29170?

CVE-2026-29170 is a medium-severity cross-site scripting vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration.

Users are recommended to upgrade to version 2.4.68, which fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-29170?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.68 |

Products: Apache Http Server.

## How do I fix CVE-2026-29170?

Upgrade apache to 2.4.68 or later.

## Is CVE-2026-29170 being exploited?

There is no known exploitation of CVE-2026-29170 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29170 and fix it if it is affected.

What it is: CVE-2026-29170 is a medium-severity cross-site scripting vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29170 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.68

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29170/ (Markdown: https://insights.sbomify.com/CVE-2026-29170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29170
- OSV: https://osv.dev/vulnerability/CVE-2026-29170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29170/
Summaries are generated and may contain mistakes; the official description above is the record.
