# CVE-2026-29172: Craft Commerce has a SQL Injection in Commerce Purchasables Table Sorting

> An authenticated attacker can inject arbitrary SQL into the ORDER BY clause of the purchasables table endpoint, potentially reading or modifying data.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-j3x5-mghf-xvfw

## What is CVE-2026-29172?

CVE-2026-29172 is a high-severity SQL injection vulnerability in craftcms commerce, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, Craft Commerce is vulnerable to SQL Injection in the purchasables table endpoint. The sort parameter is split by | and the first part (column name) is passed directly as an array key to orderBy() without whitelist validation. Yii2's query builder does NOT escape array keys, allowing an authenticated attacker to inject arbitrary SQL into the ORDER BY clause. This vulnerability is fixed in 4.10.2 and 5.5.3.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-29172?

4 open source packages ship an affected version, including craftcms/commerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/commerce` | Packagist | From 4.0.0 | 4.10.2 |
| `craftcms/commerce` | Packagist | From 4.0.0 | 4.10.2 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.5.3 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.5.3 |

Products: Craftcms Craft Commerce.

## How do I fix CVE-2026-29172?

Upgrade craftcms/commerce to a fixed version for your release line: 4.10.2 or 5.5.3.

## Is CVE-2026-29172 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29172 exists.

## Other vulnerabilities in craftcms commerce

- [CVE-2026-29174](https://insights.sbomify.com/CVE-2026-29174/): Craft Commerce has a SQL Injection in Commerce Inventory Table Sorting (high 8.7)
- [CVE-2026-29175](https://insights.sbomify.com/CVE-2026-29175/): Multiple Stored XSS in Commerce Inventory Page Leading to Session Hijacking (high 8.6)
- [CVE-2026-31867](https://insights.sbomify.com/CVE-2026-31867/): Craft Commerce has a Potential IDOR in Commerce carts (medium 6.3)
- [CVE-2026-25482](https://insights.sbomify.com/CVE-2026-25482/): Craft Commerce has Stored DOM XSS in Order Status Name (Reflects in "Recent Orders" Dashboard Widget) (medium 6.2)
- [CVE-2026-25483](https://insights.sbomify.com/CVE-2026-25483/): Craft Commerce has Stored XSS via Order Status Message with potential database exfiltration (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29172 and fix it if it is affected.

What it is: CVE-2026-29172 is a high-severity SQL injection vulnerability in craftcms commerce, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29172 exists.

Affected packages and fixed versions:
- craftcms/commerce (Packagist): affected from 4.0.0; fixed in 4.10.2
- craftcms/commerce (Packagist): affected from 4.0.0; fixed in 4.10.2
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.5.3
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29172/ (Markdown: https://insights.sbomify.com/CVE-2026-29172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29172
- OSV: https://osv.dev/vulnerability/CVE-2026-29172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29172/
Summaries are generated and may contain mistakes; the official description above is the record.
