CVE-2026-29173 Craft Commerce has Stored XSS while updating Order Status from Orders Table

Low 1.9 Published Updated

Attackers can inject malicious scripts via Order Status names in Craft Commerce, leading to stored XSS and potential session hijacking.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-29173?

CVE-2026-29173 is a low-severity cross-site scripting vulnerability in craftcms commerce, published on 10 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur. This vulnerability is fixed in 4.10.2 and 5.5.3.

Weakness: CWE-79

Which versions are affected by CVE-2026-29173?

4 open source packages ship an affected version, including craftcms/commerce. It affects 1 product.

PackageAffectedFixed in
craftcms/commerce PackagistFrom 4.0.04.10.2
craftcms/commerce PackagistFrom 4.0.04.10.2
craftcms/commerce PackagistFrom 5.0.05.5.3
craftcms/commerce PackagistFrom 5.0.05.5.3

Products include Craftcms Craft Commerce.

How do I fix CVE-2026-29173?

Upgrade craftcms/commerce to a fixed version for your release line: 4.10.2 or 5.5.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-29173 being exploited?

There is no known exploitation of CVE-2026-29173 in the wild and no public exploit code.

Sources

Also known as GHSA-mqxf-2998-c6cp.

Is CVE-2026-29173 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free