# CVE-2026-29173: Craft Commerce has Stored XSS while updating Order Status from Orders Table

> Attackers can inject malicious scripts via Order Status names in Craft Commerce, leading to stored XSS and potential session hijacking.

- **Severity:** Low 1.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-mqxf-2998-c6cp

## What is CVE-2026-29173?

CVE-2026-29173 is a low-severity cross-site scripting vulnerability in craftcms commerce, published on 10 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur. This vulnerability is fixed in 4.10.2 and 5.5.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-29173?

4 open source packages ship an affected version, including craftcms/commerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/commerce` | Packagist | From 4.0.0 | 4.10.2 |
| `craftcms/commerce` | Packagist | From 4.0.0 | 4.10.2 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.5.3 |
| `craftcms/commerce` | Packagist | From 5.0.0 | 5.5.3 |

Products: Craftcms Craft Commerce.

## How do I fix CVE-2026-29173?

Upgrade craftcms/commerce to a fixed version for your release line: 4.10.2 or 5.5.3.

## Is CVE-2026-29173 being exploited?

There is no known exploitation of CVE-2026-29173 in the wild and no public exploit code.

## Other vulnerabilities in craftcms commerce

- [CVE-2026-29172](https://insights.sbomify.com/CVE-2026-29172/): Craft Commerce has a SQL Injection in Commerce Purchasables Table Sorting (high 8.7)
- [CVE-2026-29174](https://insights.sbomify.com/CVE-2026-29174/): Craft Commerce has a SQL Injection in Commerce Inventory Table Sorting (high 8.7)
- [CVE-2026-29175](https://insights.sbomify.com/CVE-2026-29175/): Multiple Stored XSS in Commerce Inventory Page Leading to Session Hijacking (high 8.6)
- [CVE-2026-31867](https://insights.sbomify.com/CVE-2026-31867/): Craft Commerce has a Potential IDOR in Commerce carts (medium 6.3)
- [CVE-2026-25482](https://insights.sbomify.com/CVE-2026-25482/): Craft Commerce has Stored DOM XSS in Order Status Name (Reflects in "Recent Orders" Dashboard Widget) (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29173 and fix it if it is affected.

What it is: CVE-2026-29173 is a low-severity cross-site scripting vulnerability in craftcms commerce, published on 10 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29173 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/commerce (Packagist): affected from 4.0.0; fixed in 4.10.2
- craftcms/commerce (Packagist): affected from 4.0.0; fixed in 4.10.2
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.5.3
- craftcms/commerce (Packagist): affected from 5.0.0; fixed in 5.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29173/ (Markdown: https://insights.sbomify.com/CVE-2026-29173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29173
- OSV: https://osv.dev/vulnerability/CVE-2026-29173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29173/
Summaries are generated and may contain mistakes; the official description above is the record.
