CVE-2026-29175 Multiple Stored XSS in Commerce Inventory Page Leading to Session Hijacking

High 8.6 Published Updated

Attackers can inject malicious scripts into inventory fields, leading to session hijacking when administrators view the page.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-29175?

CVE-2026-29175 is a high-severity cross-site scripting vulnerability in craftcms commerce, published on 10 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 5.5.3, Stored XSS vulnerabilities exist in the Commerce Inventory page. The Product Title, Variant Title, and Variant SKU fields are rendered without proper HTML escaping, allowing an attacker to execute arbitrary JavaScript when any user (including administrators) views the inventory management page. This vulnerability is fixed in 5.5.3.

Weakness: CWE-79

Which versions are affected by CVE-2026-29175?

2 open source packages ship an affected version, including craftcms/commerce. It affects 1 product.

PackageAffectedFixed in
craftcms/commerce PackagistFrom 5.0.05.5.3
craftcms/commerce PackagistFrom 5.0.05.5.3

Products include Craftcms Craft Commerce.

How do I fix CVE-2026-29175?

Upgrade craftcms/commerce to 5.5.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-29175 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29175 exists.

Sources

Also known as GHSA-cfpv-rmpf-f624.

Is CVE-2026-29175 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free