{"answers":{"affected":"2 open source packages ship an affected version, including lemmy_routes.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29178 exists.","fix":"Upgrade lemmy_routes to 0.19.16 or later.","what":"CVE-2026-29178 is a high-severity server-side request forgery vulnerability in LemmyNet lemmy, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29178 and fix it if it is affected.\n\nWhat it is: CVE-2026-29178 is a high-severity server-side request forgery vulnerability in LemmyNet lemmy, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-29178 exists.\n\nAffected packages and fixed versions:\n- lemmy_routes (crates.io): affected all versions; fixed in 0.19.16\n- lemmy_routes (crates.io): affected all versions; fixed in 0.19.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29178/ (Markdown: https://insights.sbomify.com/CVE-2026-29178/index.md)","id":"CVE-2026-29178","markdown":"https://insights.sbomify.com/CVE-2026-29178/index.md","name":"CVE-2026-29178","record":{"aliases":["GHSA-jvxv-2jjp-jxc3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fediverse link aggregator","requires_auth":"none","summary":"Unauthenticated attackers can exploit SSRF in Lemmy's image endpoint to force the server to fetch arbitrary internal or external URLs.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Lemmy, a link aggregator and forum for the fediverse, is vulnerable to server-side request forgery via a dependency on activitypub_federation, a framework for ActivityPub federation in Rust. Prior to version 0.19.16, the GET /api/v4/image/{filename} endpoint is vulnerable to unauthenticated SSRF through parameter injection in the file_type query parameter. An attacker can inject arbitrary query parameters into the internal request to pict-rs, including the proxy parameter which causes pict-rs to fetch arbitrary URLs. This issue has been patched in version 0.19.16.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Lemmy: Unauthenticated SSRF via file_type query parameter injection in image endpoint","id":"CVE-2026-29178","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"October: Editor Sub-Permission Bypass for Asset and Blueprint File Operations","id":"CVE-2026-29179"},"packages":[{"ecosystem":"crates.io","fixed":["0.19.16"],"introduced":["0"],"last_affected":[],"package":"lemmy_routes","purl":null,"source":"GHSA-jvxv-2jjp-jxc3"},{"ecosystem":"crates.io","fixed":["0.19.16"],"introduced":["0"],"last_affected":[],"package":"lemmy_routes","purl":"pkg:cargo/lemmy_routes","source":"GHSA-jvxv-2jjp-jxc3"}],"prev":{"headline":"Craft Commerce has Stored XSS in Craft Commerce Order Details Slideout","id":"CVE-2026-29177"},"products":["lemmy"],"published":"2026-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-06","vendors":["LemmyNet"]},"summary":"Unauthenticated attackers can exploit SSRF in Lemmy's image endpoint to force the server to fetch arbitrary internal or external URLs.","url":"https://insights.sbomify.com/CVE-2026-29178/"}