# CVE-2026-29182: Parse Server: Cloud Hooks and Cloud Jobs bypass `readOnlyMasterKey` write restriction

> Attackers with the readOnlyMasterKey can bypass write restrictions to modify Cloud Hooks and start Cloud Jobs, enabling data exfiltration.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** BIT-parse-2026-29182, GHSA-vc89-5g3r-cmhh

## What is CVE-2026-29182?

CVE-2026-29182 is a high-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 6 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.4 and 9.4.1-alpha.3, Parse Server's readOnlyMasterKey option allows access with master-level read privileges but is documented to deny all write operations. However, some endpoints incorrectly accept the readOnlyMasterKey for mutating operations. This allows a caller who only holds the readOnlyMasterKey to create, modify, and delete Cloud Hooks and to start Cloud Jobs, which can be used for data exfiltration. Any Parse Server deployment that uses the readOnlyMasterKey option is affected. Note than an attacker needs to know the readOnlyMasterKey to exploit this vulnerability. This issue has been patched in versions 8.6.4 and 9.4.1-alpha.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-29182?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.4 |
| `parse-server` | npm | All versions | 8.6.4 |
| `parse-server` | npm | From 9.0.0 | 9.4.1-alpha.3 |
| `parse-server` | npm | From 9.0.0 | 9.4.1-alpha.3 |
| `parse` | Bitnami | All versions | 9.4.1 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-29182?

Upgrade parse-server to a fixed version for your release line: 8.6.4 or 9.4.1-alpha.3.

## Is CVE-2026-29182 being exploited?

There is no known exploitation of CVE-2026-29182 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29182 and fix it if it is affected.

What it is: CVE-2026-29182 is a high-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 6 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29182 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.4
- parse-server (npm): affected all versions; fixed in 8.6.4
- parse-server (npm): affected from 9.0.0; fixed in 9.4.1-alpha.3
- parse-server (npm): affected from 9.0.0; fixed in 9.4.1-alpha.3
- parse (Bitnami): affected all versions; fixed in 9.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29182/ (Markdown: https://insights.sbomify.com/CVE-2026-29182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29182
- OSV: https://osv.dev/vulnerability/CVE-2026-29182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29182/
Summaries are generated and may contain mistakes; the official description above is the record.
