# CVE-2026-29184: @backstage/plugin-scaffolder-backend: Potential Session Token Exfiltration via Log Redaction Bypass

> A malicious scaffolder template can bypass log redaction to exfiltrate secrets via task event logs in Backstage developer portals.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-8qp7-fhr9-fw53

## What is CVE-2026-29184?

CVE-2026-29184 is a low-severity vulnerability in backstage, published on 7 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Backstage is an open framework for building developer portals. Prior to version 3.1.4, a malicious scaffolder template can bypass the log redaction mechanism to exfiltrate secrets provided run through task event logs. This issue has been patched in version 3.1.4.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-29184?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 3.1.4 |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 3.1.4 |

Products: Linuxfoundation Backstage\/Plugin-Scaffolder-Backend.

## How do I fix CVE-2026-29184?

Upgrade @backstage/plugin-scaffolder-backend to 3.1.4 or later.

## Is CVE-2026-29184 being exploited?

There is no known exploitation of CVE-2026-29184 in the wild and no public exploit code.

## Other vulnerabilities in backstage

- [CVE-2026-32237](https://insights.sbomify.com/CVE-2026-32237/): @backstage/plugin-scaffolder-backend: Possible exposure of defaultEnvironment secrets using dry-run endpoint (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29184 and fix it if it is affected.

What it is: CVE-2026-29184 is a low-severity vulnerability in backstage, published on 7 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29184 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 3.1.4
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29184/ (Markdown: https://insights.sbomify.com/CVE-2026-29184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29184
- OSV: https://osv.dev/vulnerability/CVE-2026-29184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29184/
Summaries are generated and may contain mistakes; the official description above is the record.
